summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-01 00:30:29 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-01 00:30:29 +0000
commit6746debb10929bfefab0e026ff61ac09b5d01c61 (patch)
tree5b11725b61bfc9abff6174104b90430b3d15fe82 /dev-python/keyring
parentebuild format update to distutils-r1 and eapi5 (diff)
downloadgentoo-2-6746debb10929bfefab0e026ff61ac09b5d01c61.tar.gz
gentoo-2-6746debb10929bfefab0e026ff61ac09b5d01c61.tar.bz2
gentoo-2-6746debb10929bfefab0e026ff61ac09b5d01c61.zip
update to eapi5 and distutils-r1
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/ChangeLog8
-rw-r--r--dev-python/keyring/keyring-1.0.ebuild30
2 files changed, 17 insertions, 21 deletions
diff --git a/dev-python/keyring/ChangeLog b/dev-python/keyring/ChangeLog
index d88e3d61a9be..99a09b10758a 100644
--- a/dev-python/keyring/ChangeLog
+++ b/dev-python/keyring/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/keyring
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/ChangeLog,v 1.2 2012/12/28 05:34:57 prometheanfire Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/ChangeLog,v 1.3 2013/01/01 00:30:29 prometheanfire Exp $
+
+ 01 Jan 2013; Matthew Thode <prometheanfire@gentoo.org> keyring-1.0.ebuild:
+ update to eapi5 and distutils-r1
28 Dec 2012; Matthew Thode <prometheanfire@gentoo.org> keyring-1.0.ebuild,
+files/setup-1.0.patch:
@@ -10,4 +13,3 @@
19 Dec 2012; <mthode@gentoo.org> +keyring-1.0.ebuild, +metadata.xml:
initial commit of python keyring
-
diff --git a/dev-python/keyring/keyring-1.0.ebuild b/dev-python/keyring/keyring-1.0.ebuild
index fc0664696f0b..5775c012630c 100644
--- a/dev-python/keyring/keyring-1.0.ebuild
+++ b/dev-python/keyring/keyring-1.0.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/keyring-1.0.ebuild,v 1.2 2012/12/28 05:34:57 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/keyring-1.0.ebuild,v 1.3 2013/01/01 00:30:29 prometheanfire Exp $
# Ebuild generated by g-pypi 0.2.2 (rev. 214)
-EAPI=4
+EAPI=5
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-inherit distutils eutils
+inherit distutils-r1 eutils
MY_PN=${PN#python-}
S="${WORKDIR}/${MY_PN}-${PV}"
@@ -17,23 +18,16 @@ LICENSE="PSF-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="test"
-DEPEND="dev-python/setuptools
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest
dev-python/pytest-runner
dev-python/unittest2 )"
RDEPEND=""
+PATCHES=( "${FILESDIR}/setup-1.0.patch" )
-src_prepare() {
- epatch "${FILESDIR}/setup-1.0.patch"
-}
-
-src_test() {
- PYTHONPATH="build/lib" "$(PYTHON)" keyring/tests/test_util.py
- PYTHONPATH="build/lib" "$(PYTHON)" keyring/tests/test_backend.py
- PYTHONPATH="build/lib" "$(PYTHON)" keyring/tests/test_core.py
- PYTHONPATH="build/lib" "$(PYTHON)" keyring/tests/test_cli.py
-}
-
-src_install() {
- distutils_src_install
+python_test() {
+ "${PYTHON}" keyring/tests/test_util.py || die
+ "${PYTHON}" keyring/tests/test_backend.py || die
+ "${PYTHON}" keyring/tests/test_core.py || die
+ "${PYTHON}" keyring/tests/test_cli.py || die
}