summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-02-03 11:15:31 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-02-03 11:15:31 +0000
commitc2d7337343e7e005e68bfd735930a98ac40ba7d5 (patch)
tree349321a0e4bd1ec4cbffe2ef4df04cf74fad2605 /dev-python/ipython
parentDon't use egamesinstall (diff)
downloadgentoo-2-c2d7337343e7e005e68bfd735930a98ac40ba7d5.tar.gz
gentoo-2-c2d7337343e7e005e68bfd735930a98ac40ba7d5.tar.bz2
gentoo-2-c2d7337343e7e005e68bfd735930a98ac40ba7d5.zip
Added 50ipython-mode-gentoo.el from bug 92218 and inherit from elisp-common to complete emacs support (thanks to dan).
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ChangeLog7
-rw-r--r--dev-python/ipython/files/50ipython-mode-gentoo.el1
-rw-r--r--dev-python/ipython/ipython-0.7.3.ebuild23
3 files changed, 24 insertions, 7 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index 84a856ff4bfe..1148ada15aee 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ipython
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.32 2007/02/03 10:44:59 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.33 2007/02/03 11:15:31 dev-zero Exp $
+
+ 03 Feb 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +files/50ipython-mode-gentoo.el, ipython-0.7.3.ebuild:
+ Added 50ipython-mode-gentoo.el from bug 92218 and inherit from elisp-common
+ to complete emacs support (thanks to dan).
*ipython-0.7.3 (03 Feb 2007)
diff --git a/dev-python/ipython/files/50ipython-mode-gentoo.el b/dev-python/ipython/files/50ipython-mode-gentoo.el
new file mode 100644
index 000000000000..818864f83ecb
--- /dev/null
+++ b/dev-python/ipython/files/50ipython-mode-gentoo.el
@@ -0,0 +1 @@
+(require 'ipython) \ No newline at end of file
diff --git a/dev-python/ipython/ipython-0.7.3.ebuild b/dev-python/ipython/ipython-0.7.3.ebuild
index 6498f8c7ee72..7ae68094b204 100644
--- a/dev-python/ipython/ipython-0.7.3.ebuild
+++ b/dev-python/ipython/ipython-0.7.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.7.3.ebuild,v 1.2 2007/02/03 10:55:56 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.7.3.ebuild,v 1.3 2007/02/03 11:15:31 dev-zero Exp $
NEED_PYTHON=2.3
-inherit distutils
+inherit distutils elisp-common
DESCRIPTION="An advanced interactive shell for Python."
HOMEPAGE="http://ipython.scipy.org/"
@@ -15,10 +15,13 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~s390 ~x86"
IUSE="doc examples emacs gnuplot test"
-DEPEND="test? ( dev-python/pexpect )"
-RDEPEND="gnuplot? ( dev-python/gnuplot-py )"
+RDEPEND="gnuplot? ( dev-python/gnuplot-py )
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pexpect )"
PYTHON_MODNAME="IPython"
+SITEFILE="50ipython-mode-gentoo.el"
src_unpack() {
unpack ${A}
@@ -31,6 +34,14 @@ src_unpack() {
setup.py || die "sed failed"
}
+src_compile() {
+ distutils_src_compile
+ if use emacs ; then
+ cd doc
+ elisp-comp ipython.el || die "elisp-comp failed"
+ fi
+}
+
src_install() {
DOCS="doc/ChangeLog"
distutils_src_install
@@ -46,7 +57,7 @@ src_install() {
doins -r examples
fi
if use emacs ; then
- insinto /usr/share/emacs/site-lisp
- doins ipython.el
+ elisp-install ${PN} ipython.el ipython.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
}