summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-09 17:08:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-09 17:08:09 +0000
commit3a70a0aea41e371ff249b03bf52bc1c6f027d31f (patch)
tree24ad5dda141fee5c19f6080bee0294e8f624090c /dev-python/ipython
parentRemove ncftp dependency - the related script checks for this (or we should be... (diff)
downloadgentoo-2-3a70a0aea41e371ff249b03bf52bc1c6f027d31f.tar.gz
gentoo-2-3a70a0aea41e371ff249b03bf52bc1c6f027d31f.tar.bz2
gentoo-2-3a70a0aea41e371ff249b03bf52bc1c6f027d31f.zip
Version bump.
(Portage version: 2.2.0_alpha29_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ChangeLog8
-rw-r--r--dev-python/ipython/ipython-0.10.2.ebuild106
2 files changed, 113 insertions, 1 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index fc58331379eb..05dc4dc51f59 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ipython
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.80 2011/01/07 14:41:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.81 2011/04/09 17:08:09 arfrever Exp $
+
+*ipython-0.10.2 (09 Apr 2011)
+
+ 09 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +ipython-0.10.2.ebuild:
+ Version bump.
07 Jan 2011; Brent Baude <ranger@gentoo.org> ipython-0.10.1.ebuild:
Marking ipython-0.10.1 ppc for bug 345495
diff --git a/dev-python/ipython/ipython-0.10.2.ebuild b/dev-python/ipython/ipython-0.10.2.ebuild
new file mode 100644
index 000000000000..0cfefcccb702
--- /dev/null
+++ b/dev-python/ipython/ipython-0.10.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.10.2.ebuild,v 1.1 2011/04/09 17:08:09 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+# When a new version of this package supports Python 3, then 3.* Python ABIs should be unrestricted in dev-python/ipdb.
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils elisp-common eutils
+
+DESCRIPTION="An interactive computing environment for Python"
+HOMEPAGE="http://ipython.scipy.org/ http://pypi.python.org/pypi/ipython"
+SRC_URI="http://ipython.scipy.org/dist/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc emacs examples gnuplot readline smp test wxwidgets"
+
+RDEPEND="dev-python/pexpect
+ emacs? (
+ app-emacs/python-mode
+ virtual/emacs
+ )
+ gnuplot? ( dev-python/gnuplot-py )
+ readline? ( sys-libs/readline )
+ smp? (
+ dev-python/foolscap
+ dev-python/pyopenssl
+ net-zope/zope-interface
+ )
+ wxwidgets? ( dev-python/wxpython )"
+DEPEND="${DEPEND}
+ test? ( dev-python/nose )"
+
+DOCS="docs/source/changes.txt"
+PYTHON_MODNAME="IPython"
+
+SITEFILE="62ipython-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.9.1-globalpath.patch"
+ sed -e "s:share/doc/ipython:share/doc/${PF}:" -i setupbase.py || die "sed failed"
+
+ if ! use doc; then
+ sed \
+ -e "/extensions/d" \
+ -e "s/+ manual_files//" \
+ -i setupbase.py || die "sed failed"
+ fi
+
+ if ! use examples; then
+ sed -e "s/+ example_files//" -i setupbase.py || die "sed failed"
+ fi
+
+ # Don't install files requiring Numeric.
+ rm -f IPython/numutils.py IPython/UserConfig/ipythonrc-numeric
+
+ # Disable failing test.
+ sed -e "s/test_obj_del/_&/" -i IPython/tests/test_magic.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use emacs; then
+ elisp-compile docs/emacs/ipython.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home="${WORKDIR}/test-${PYTHON_ABI}" > /dev/null || die "Installation for tests failed with $(python_get_implementation) $(python_get_version)"
+ pushd "${WORKDIR}/test-${PYTHON_ABI}" > /dev/null
+ # First initialize .ipython stuff.
+ PATH="${WORKDIR}/test-${PYTHON_ABI}/bin:${PATH}" PYTHONPATH="${WORKDIR}/test-${PYTHON_ABI}/lib/python" ipython > /dev/null <<-EOF
+ EOF
+ # Run tests (-v for more verbosity).
+ PATH="${WORKDIR}/test-${PYTHON_ABI}/bin:${PATH}" PYTHONPATH="${WORKDIR}/test-${PYTHON_ABI}/lib/python" iptest -v
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use emacs; then
+ pushd docs/emacs > /dev/null
+ elisp-install ${PN} ${PN}.el* || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ popd > /dev/null
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}