summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-12 11:52:02 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-12 11:52:02 +0000
commitd1644f315f4a77b9d40d26dbc0b5c357185daf4f (patch)
tree0a4cc49a97bc16a755e1c7cee9aa72d96458e7cd /dev-python/imapclient
parentStable for HPPA (bug #529964). (diff)
downloadgentoo-2-d1644f315f4a77b9d40d26dbc0b5c357185daf4f.tar.gz
gentoo-2-d1644f315f4a77b9d40d26dbc0b5c357185daf4f.tar.bz2
gentoo-2-d1644f315f4a77b9d40d26dbc0b5c357185daf4f.zip
drop py3.2 add py3.4, tidy deps fix test phase, fixes Bug #530524 by pacho2
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/imapclient')
-rw-r--r--dev-python/imapclient/ChangeLog5
-rw-r--r--dev-python/imapclient/imapclient-0.11.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/dev-python/imapclient/ChangeLog b/dev-python/imapclient/ChangeLog
index 2a7ac8e2e972..d78b2b534f57 100644
--- a/dev-python/imapclient/ChangeLog
+++ b/dev-python/imapclient/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/imapclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imapclient/ChangeLog,v 1.3 2014/05/31 03:59:35 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imapclient/ChangeLog,v 1.4 2014/12/12 11:52:02 idella4 Exp $
+
+ 12 Dec 2014; Ian Delaney <idella4@gentoo.org> imapclient-0.11.ebuild:
+ drop py3.2 add py3.4, tidy deps fix test phase, fixes Bug #530524 by pacho2
*imapclient-0.11 (31 May 2014)
diff --git a/dev-python/imapclient/imapclient-0.11.ebuild b/dev-python/imapclient/imapclient-0.11.ebuild
index 8cad58bb78bd..b4f8470cf627 100644
--- a/dev-python/imapclient/imapclient-0.11.ebuild
+++ b/dev-python/imapclient/imapclient-0.11.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imapclient/imapclient-0.11.ebuild,v 1.1 2014/05/31 03:59:35 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imapclient/imapclient-0.11.ebuild,v 1.2 2014/12/12 11:52:02 idella4 Exp $
EAPI=5
-# "Python versions 2.6, 2.7, 3.2 and 3.3 are officially supported" therefore
-# NOT adding py3.4 since it doesn't testsuite desn't even get started since it's clearly not ready
-PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -24,7 +23,7 @@ IUSE="doc examples test"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+ test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy) )"
S=${WORKDIR}/${MY_P}
@@ -47,7 +46,7 @@ python_prepare_all() {
}
python_test() {
- esetup.py test
+ "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
}
python_install() {