summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 22:21:34 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 22:21:34 +0000
commitb6214f350c61c25c24346033ce3a6bbb9f513ae7 (patch)
treee81c9c0861fb576e4b3153c0330b4e1839f17361 /dev-python/iconvcodec
parentMarking i18n-0.3.7 ~ppc64 for bug 321283 (diff)
downloadgentoo-2-b6214f350c61c25c24346033ce3a6bbb9f513ae7.tar.gz
gentoo-2-b6214f350c61c25c24346033ce3a6bbb9f513ae7.tar.bz2
gentoo-2-b6214f350c61c25c24346033ce3a6bbb9f513ae7.zip
Update EAPI. Fix dependencies. Support installation for multiple Python ABIs.
(Portage version: 2.2_rc88_p40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/iconvcodec')
-rw-r--r--dev-python/iconvcodec/ChangeLog6
-rw-r--r--dev-python/iconvcodec/iconvcodec-1.1.2.ebuild20
2 files changed, 19 insertions, 7 deletions
diff --git a/dev-python/iconvcodec/ChangeLog b/dev-python/iconvcodec/ChangeLog
index ab37567919e5..4c573a968eac 100644
--- a/dev-python/iconvcodec/ChangeLog
+++ b/dev-python/iconvcodec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/iconvcodec
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/iconvcodec/ChangeLog,v 1.9 2010/09/29 21:42:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/iconvcodec/ChangeLog,v 1.10 2010/09/29 22:21:34 arfrever Exp $
+
+ 29 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ iconvcodec-1.1.2.ebuild:
+ Update EAPI. Fix dependencies. Support installation for multiple Python ABIs.
29 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-iconvcodec-1.1.1.ebuild:
diff --git a/dev-python/iconvcodec/iconvcodec-1.1.2.ebuild b/dev-python/iconvcodec/iconvcodec-1.1.2.ebuild
index b8e7afeb7a04..ce672b8eb162 100644
--- a/dev-python/iconvcodec/iconvcodec-1.1.2.ebuild
+++ b/dev-python/iconvcodec/iconvcodec-1.1.2.ebuild
@@ -1,19 +1,27 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/iconvcodec/iconvcodec-1.1.2.ebuild,v 1.7 2009/02/15 22:26:38 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/iconvcodec/iconvcodec-1.1.2.ebuild,v 1.8 2010/09/29 22:21:34 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="Python Codecs for Iconv Encodings"
-SRC_URI="mirror://berlios/cjkpython/${P}.tar.gz"
HOMEPAGE="http://cjkpython.i18n.org/"
+SRC_URI="mirror://berlios/cjkpython/${P}.tar.gz"
-IUSE=""
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="~amd64 ia64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
-DEPEND=">=dev-lang/python-1.6"
+PYTHON_MODNAME="iconv_codec.py"
src_compile() {
distutils_src_compile --with-libc