summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-11 07:19:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-11 07:19:58 +0000
commitf05502a3810f6a9a4a1c7c397436ea24279cee52 (patch)
treeaa02d21b2e970867e70eea3c7bae1cf7b1d2cf3a /dev-python/httplib2
parentBump for #410791 (diff)
downloadgentoo-2-f05502a3810f6a9a4a1c7c397436ea24279cee52.tar.gz
gentoo-2-f05502a3810f6a9a4a1c7c397436ea24279cee52.tar.bz2
gentoo-2-f05502a3810f6a9a4a1c7c397436ea24279cee52.zip
Bump for #410803, restricting tests
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog9
-rw-r--r--dev-python/httplib2/httplib2-0.7.4.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 1071e161df6b..472da598826e 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/httplib2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.27 2011/11/30 15:56:32 neurogeek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.28 2012/04/11 07:19:58 patrick Exp $
+
+*httplib2-0.7.4 (11 Apr 2012)
+
+ 11 Apr 2012; Patrick Lauer <patrick@gentoo.org> +httplib2-0.7.4.ebuild:
+ Bump for #410803, restricting tests
*httplib2-0.7.2 (30 Nov 2011)
diff --git a/dev-python/httplib2/httplib2-0.7.4.ebuild b/dev-python/httplib2/httplib2-0.7.4.ebuild
new file mode 100644
index 000000000000..e01dad579edb
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.7.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.4.ebuild,v 1.1 2012/04/11 07:19:58 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+RESTRICT="test" # tests connect to random remote sites and exploderate badly
+
+inherit distutils
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3.*"
+#Restrict Python 3 support until upstream
+#issue #189 is solved
+
+src_test() {
+ testing() {
+ pushd "python$(python_get_version --major)" > /dev/null
+ "$(PYTHON)" httplib2test.py
+ popd > /dev/null
+ }
+ python_execute_function testing
+}