summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-11-30 15:56:32 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-11-30 15:56:32 +0000
commit02fd4216a331cb17969bf93de6ae4cc93a38687e (patch)
tree83f4408d3c80cc45a1e2194dc5fcca638f29ee83 /dev-python/httplib2
parentupdate the man-page cleanup patch (bug #392601) (diff)
downloadgentoo-2-02fd4216a331cb17969bf93de6ae4cc93a38687e.tar.gz
gentoo-2-02fd4216a331cb17969bf93de6ae4cc93a38687e.tar.bz2
gentoo-2-02fd4216a331cb17969bf93de6ae4cc93a38687e.zip
Version bump. Dropped support for Py3.
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog7
-rw-r--r--dev-python/httplib2/httplib2-0.7.2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 575c6481ce1a..1071e161df6b 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/httplib2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.26 2011/09/24 13:38:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.27 2011/11/30 15:56:32 neurogeek Exp $
+
+*httplib2-0.7.2 (30 Nov 2011)
+
+ 30 Nov 2011; Jesus Rivero <neurogeek@gentoo.org> +httplib2-0.7.2.ebuild:
+ Version bump. Dropped support for Py3.
24 Sep 2011; Fabian Groffen <grobian@gentoo.org> httplib2-0.7.1.ebuild:
Marked ~x64-macos
diff --git a/dev-python/httplib2/httplib2-0.7.2.ebuild b/dev-python/httplib2/httplib2-0.7.2.ebuild
new file mode 100644
index 000000000000..e9892eed01cc
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.2.ebuild,v 1.1 2011/11/30 15:56:32 neurogeek Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3.*"
+#Restrict Python 3 support until upstream
+#issue #189 is solved
+
+src_test() {
+ testing() {
+ pushd "python$(python_get_version --major)" > /dev/null
+ "$(PYTHON)" httplib2test.py
+ popd > /dev/null
+ }
+ python_execute_function testing
+}