summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-08-19 01:11:58 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-08-19 01:11:58 +0000
commitf5bbbbb9fc518e4ff8d4518d2140691a92cc2540 (patch)
tree4f7c8463f54e214472f33a6ee19928c3af824a72 /dev-python/htmlgen
parentAdd patch from Debian for CVE 2007-0227. Run updatedb through ionice #231203... (diff)
downloadgentoo-2-f5bbbbb9fc518e4ff8d4518d2140691a92cc2540.tar.gz
gentoo-2-f5bbbbb9fc518e4ff8d4518d2140691a92cc2540.tar.bz2
gentoo-2-f5bbbbb9fc518e4ff8d4518d2140691a92cc2540.zip
Minor enhancements to the ebuild. Thanks to Necoro <gentoo@necoro.eu>. Bug #233646
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/htmlgen')
-rw-r--r--dev-python/htmlgen/ChangeLog8
-rw-r--r--dev-python/htmlgen/htmlgen-2.2.2.ebuild52
2 files changed, 39 insertions, 21 deletions
diff --git a/dev-python/htmlgen/ChangeLog b/dev-python/htmlgen/ChangeLog
index 24e5135b8a3a..6b72ec2d9ab9 100644
--- a/dev-python/htmlgen/ChangeLog
+++ b/dev-python/htmlgen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/htmlgen
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/ChangeLog,v 1.9 2006/07/12 15:39:25 agriffis Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/ChangeLog,v 1.10 2008/08/19 01:11:58 neurogeek Exp $
+
+ 18 Aug 2008; Jesus Rivero <neurogeek@gentoo.org> htmlgen-2.2.2.ebuild:
+ Minor enhancements to the ebuild. Thanks to Necoro <gentoo@necoro.eu>. Bug
+ #233646
12 Jul 2006; Aron Griffis <agriffis@gentoo.org> htmlgen-2.2.2.ebuild:
Mark 2.2.2 stable on ia64
diff --git a/dev-python/htmlgen/htmlgen-2.2.2.ebuild b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
index f5f010341d4c..fe1383b3b607 100644
--- a/dev-python/htmlgen/htmlgen-2.2.2.ebuild
+++ b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/htmlgen-2.2.2.ebuild,v 1.12 2006/07/12 15:39:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/htmlgen-2.2.2.ebuild,v 1.13 2008/08/19 01:11:58 neurogeek Exp $
+
+inherit python
-IUSE=""
MY_P="HTMLgen"
DESCRIPTION="HTMLgen - Python modules for the generation of HTML documents"
HOMEPAGE="http://starship.python.net/crew/friedrich/HTMLgen/html/main.html"
@@ -11,28 +12,41 @@ SRC_URI="http://starship.python.net/crew/friedrich/${MY_P}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="ia64 ppc x86"
+IUSE="doc"
DEPEND="virtual/python
dev-python/imaging"
S="${WORKDIR}/${MY_P}"
-src_compile() {
- make compileall || die "make failed"
-}
-
src_install() {
- PYTHON_VER=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
# doing this manually because their build scripts suck
- dodir /usr/lib/python${PYTHON_VER}/site-packages
- insinto /usr/lib/python${PYTHON_VER}/site-packages
- doins HTMLgen.py HTMLcolors.py HTMLutil.py HTMLcalendar.py
- doins barchart.py colorcube.py imgsize.py NavLinks.py
- doins Formtools.py HTMLgen.pyc HTMLcolors.pyc HTMLutil.pyc
- doins HTMLcalendar.pyc barchart.pyc colorcube.pyc imgsize.pyc
- doins NavLinks.pyc Formtools.pyc ImageH.py ImageFileH.py
- doins ImagePaletteH.py GifImagePluginH.py JpegImagePluginH.py
- doins PngImagePluginH.py ImageH.pyc ImageFileH.pyc
- doins ImagePaletteH.pyc GifImagePluginH.pyc JpegImagePluginH.pyc
- doins PngImagePluginH.pyc
+ local files="HTMLgen.py HTMLcolors.py HTMLutil.py HTMLcalendar.py \
+ barchart.py colorcube.py imgsize.py NavLinks.py Formtools.py \
+ ImageH.py ImageFileH.py ImagePaletteH.py GifImagePluginH.py \
+ JpegImagePluginH.py PngImagePluginH.py"
+
+ touch __init__.py
+
+ insinto $(python_get_sitedir)/htmlgen
+ doins $files __init__.py || die "doins failed"
+
+ if use doc; then
+ # fix the image locations in the docs
+ sed -i -e "s;../image/;image/;g" html/* || die "sed failed"
+ dohtml html/*
+ dohtml -r image
+ fi
+ dodoc README
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/htmlgen
+
+ ewarn "htmlgen now resides in its own subdirectory"
+ ewarn "so you need to do \"from htmlgen import HTMLgen\" instead of \"import HTMLgen\""
+}
+
+pkg_postrm () {
+ python_mod_cleanup $(python_get_sitedir)/htmlgen
}