summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-23 02:36:02 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-23 02:36:02 +0000
commit9c04c1e56f9dcafe04c2a8f22faae88dfe233766 (patch)
tree7bbf19d0a5fd52e187ca6c63c837ea5dbb63b4c6 /dev-python/hgdistver
parentremove old (diff)
downloadgentoo-2-9c04c1e56f9dcafe04c2a8f22faae88dfe233766.tar.gz
gentoo-2-9c04c1e56f9dcafe04c2a8f22faae88dfe233766.tar.bz2
gentoo-2-9c04c1e56f9dcafe04c2a8f22faae88dfe233766.zip
bump; Clean old impls, add py3.4, correct test pahse
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/hgdistver')
-rw-r--r--dev-python/hgdistver/ChangeLog8
-rw-r--r--dev-python/hgdistver/hgdistver-0.16-r1.ebuild4
-rw-r--r--dev-python/hgdistver/hgdistver-0.18.ebuild25
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-python/hgdistver/ChangeLog b/dev-python/hgdistver/ChangeLog
index 606b84c8ffee..625aba8c9f17 100644
--- a/dev-python/hgdistver/ChangeLog
+++ b/dev-python/hgdistver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/hgdistver
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hgdistver/ChangeLog,v 1.11 2014/06/08 11:08:24 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hgdistver/ChangeLog,v 1.12 2014/06/23 02:36:02 idella4 Exp $
+
+*hgdistver-0.18 (23 Jun 2014)
+
+ 23 Jun 2014; Ian Delaney <idella4@gentoo.org> +hgdistver-0.18.ebuild,
+ hgdistver-0.16-r1.ebuild:
+ bump; Clean old impls, add py3.4, correct test pahse
08 Jun 2014; Akinori Hattori <hattya@gentoo.org> hgdistver-0.16-r1.ebuild,
hgdistver-0.16.ebuild:
diff --git a/dev-python/hgdistver/hgdistver-0.16-r1.ebuild b/dev-python/hgdistver/hgdistver-0.16-r1.ebuild
index 6f5fe0ebcf50..3a591484db58 100644
--- a/dev-python/hgdistver/hgdistver-0.16-r1.ebuild
+++ b/dev-python/hgdistver/hgdistver-0.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hgdistver/hgdistver-0.16-r1.ebuild,v 1.9 2014/06/08 11:08:24 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hgdistver/hgdistver-0.16-r1.ebuild,v 1.10 2014/06/23 02:36:02 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
@@ -22,5 +22,5 @@ RDEPEND=""
python_test() {
# https://bitbucket.org/RonnyPfannschmidt/hgdistver/issue/9/test-failures; train wreck
- nosetests || die "Tests failed under ${EPYTHON}"
+ py.test || die "Tests failed under ${EPYTHON}"
}
diff --git a/dev-python/hgdistver/hgdistver-0.18.ebuild b/dev-python/hgdistver/hgdistver-0.18.ebuild
new file mode 100644
index 000000000000..6c25ac48c24d
--- /dev/null
+++ b/dev-python/hgdistver/hgdistver-0.18.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hgdistver/hgdistver-0.18.ebuild,v 1.1 2014/06/23 02:36:02 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="utility lib to generate python package version infos from mercurial tags"
+HOMEPAGE="http://bitbucket.org/RonnyPfannschmidt/hgdistver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}