summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-22 16:12:19 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-22 16:12:19 +0000
commit6ad2b7f312d70daf619487097512a8a46a4e85c0 (patch)
tree61ce3806b410ba90fde292a9a770b09a0db462e4 /dev-python/hcluster
parentMask the python use flag for >=app-accessibility/brltty-4.5 because (diff)
downloadgentoo-2-6ad2b7f312d70daf619487097512a8a46a4e85c0.tar.gz
gentoo-2-6ad2b7f312d70daf619487097512a8a46a4e85c0.tar.bz2
gentoo-2-6ad2b7f312d70daf619487097512a8a46a4e85c0.zip
revbump; migrate to distutils-r1, remove old, correct deps
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/hcluster')
-rw-r--r--dev-python/hcluster/ChangeLog11
-rw-r--r--dev-python/hcluster/hcluster-0.2.0-r1.ebuild (renamed from dev-python/hcluster/hcluster-0.2.0.ebuild)18
2 files changed, 16 insertions, 13 deletions
diff --git a/dev-python/hcluster/ChangeLog b/dev-python/hcluster/ChangeLog
index 727164053875..87e3e9ba2b19 100644
--- a/dev-python/hcluster/ChangeLog
+++ b/dev-python/hcluster/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/hcluster
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hcluster/ChangeLog,v 1.4 2012/02/23 09:08:34 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hcluster/ChangeLog,v 1.5 2013/06/22 16:12:19 idella4 Exp $
+
+*hcluster-0.2.0-r1 (22 Jun 2013)
+
+ 22 Jun 2013; Ian Delaney <idella4@gentoo.org> +hcluster-0.2.0-r1.ebuild,
+ -hcluster-0.2.0.ebuild:
+ revbump; migrate to distutils-r1, remove old, correct deps
23 Feb 2012; Patrick Lauer <patrick@gentoo.org> hcluster-0.2.0.ebuild:
Restricting python
@@ -20,4 +26,3 @@
05 Dec 2008; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+hcluster-0.1.9.ebuild:
Initial import
-
diff --git a/dev-python/hcluster/hcluster-0.2.0.ebuild b/dev-python/hcluster/hcluster-0.2.0-r1.ebuild
index 6f30b22ae47f..6e6c31c2d212 100644
--- a/dev-python/hcluster/hcluster-0.2.0.ebuild
+++ b/dev-python/hcluster/hcluster-0.2.0-r1.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hcluster/hcluster-0.2.0.ebuild,v 1.3 2012/02/23 09:08:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hcluster/hcluster-0.2.0-r1.ebuild,v 1.1 2013/06/22 16:12:19 idella4 Exp $
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="Python hierarchical clustering package for Scipy"
HOMEPAGE="http://code.google.com/p/scipy-cluster/ http://pypi.python.org/pypi/hcluster"
@@ -18,9 +16,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/matplotlib
- dev-python/numpy"
-RDEPEND="${DEPEND}"
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/matplotlib[${PYTHON_USEDEP}]"
# Tests need X display with matplotlib.
RESTRICT="test"