summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-08-24 07:28:35 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-08-24 07:28:35 +0000
commit9db7a8e71bc411ac7a47b626ec1bee6f41bd7d1f (patch)
tree767c4fbaddb321b0f8727f0662168af1a83e2399 /dev-python/gnome-vfs-python
parentInitial import of gnome-python split ebuilds. This package installs bindings ... (diff)
downloadgentoo-2-9db7a8e71bc411ac7a47b626ec1bee6f41bd7d1f.tar.gz
gentoo-2-9db7a8e71bc411ac7a47b626ec1bee6f41bd7d1f.tar.bz2
gentoo-2-9db7a8e71bc411ac7a47b626ec1bee6f41bd7d1f.zip
Initial import of gnome-python split ebuilds. This package installs bindings for the GnomeVFS library.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 i686)
Diffstat (limited to 'dev-python/gnome-vfs-python')
-rw-r--r--dev-python/gnome-vfs-python/ChangeLog11
-rw-r--r--dev-python/gnome-vfs-python/Manifest4
-rw-r--r--dev-python/gnome-vfs-python/gnome-vfs-python-2.22.1.ebuild22
-rw-r--r--dev-python/gnome-vfs-python/metadata.xml6
4 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/gnome-vfs-python/ChangeLog b/dev-python/gnome-vfs-python/ChangeLog
new file mode 100644
index 000000000000..5b8c7efe2548
--- /dev/null
+++ b/dev-python/gnome-vfs-python/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/gnome-vfs-python
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-vfs-python/ChangeLog,v 1.1 2008/08/24 07:28:35 ford_prefect Exp $
+
+*gnome-vfs-python-2.22.1 (24 Aug 2008)
+
+ 24 Aug 2008; Arun Raghavan <ford_prefect@gentoo.org> +metadata.xml,
+ +gnome-vfs-python-2.22.1.ebuild:
+ Initial import of gnome-python split ebuilds. This package installs
+ bindings for the GnomeVFS library.
+
diff --git a/dev-python/gnome-vfs-python/Manifest b/dev-python/gnome-vfs-python/Manifest
new file mode 100644
index 000000000000..5f5eede194e5
--- /dev/null
+++ b/dev-python/gnome-vfs-python/Manifest
@@ -0,0 +1,4 @@
+DIST gnome-python-2.22.1.tar.bz2 552363 RMD160 f2e4033cf74822c939cb14cdb69f9583e07fbf25 SHA1 91402febafd40d59c0eb3f9da80a3406e4e7a76e SHA256 559b5d857b4fbc31418bc677f3391182ba1c357cabb8dfee04a1e709a7a63d01
+EBUILD gnome-vfs-python-2.22.1.ebuild 587 RMD160 945eaea615063b4fca43f990a82e6149b470d794 SHA1 b023d5a8d2a11cc243225ec814d2ec5ec0abfb1b SHA256 bc8eb77645641d7a208f73759c71a22b8c303331d1ad09181c0ed5c66a900d71
+MISC ChangeLog 381 RMD160 5685cd0c5b8aa8b095f5fcc0712c6455d3a76b02 SHA1 260c0bc39eb59fc4ea62106df0f3d7287e3a6e92 SHA256 3eec8a9f0124471efc38137096f7d463ec88f8e73b71295a2b2b903a2f25ccd7
+MISC metadata.xml 178 RMD160 ec0937689a645defb2b870b481c4d4db57a0fa73 SHA1 aa77d904544ca6e6e684658ec652463fdb2ca58d SHA256 ccdf4a821074a281d4fd442460b65f57e77546cea36756c435db5529d22fa2a6
diff --git a/dev-python/gnome-vfs-python/gnome-vfs-python-2.22.1.ebuild b/dev-python/gnome-vfs-python/gnome-vfs-python-2.22.1.ebuild
new file mode 100644
index 000000000000..e93a968eb55c
--- /dev/null
+++ b/dev-python/gnome-vfs-python/gnome-vfs-python-2.22.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-vfs-python/gnome-vfs-python-2.22.1.ebuild,v 1.1 2008/08/24 07:28:35 ford_prefect Exp $
+
+G_PY_PN="gnome-python"
+G_PY_BINDINGS="gnomevfs gnomevfsbonobo pyvfsmodule"
+
+inherit gnome-python-common
+
+DESCRIPTION="Python bindings for the GnomeVFS library"
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=gnome-base/gnome-vfs-2.14.0
+ >=gnome-base/libbonobo-2.8
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}"
+
+EXAMPLES="examples/vfs/*
+ examples/vfs/pygvfsmethod/"
diff --git a/dev-python/gnome-vfs-python/metadata.xml b/dev-python/gnome-vfs-python/metadata.xml
new file mode 100644
index 000000000000..888e60bf6a90
--- /dev/null
+++ b/dev-python/gnome-vfs-python/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<herd>gnome</herd>
+</pkgmetadata>