summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-11 19:09:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-11 19:09:57 +0000
commit634c983f685fd70ce70be3a41d452a2cbca9adc4 (patch)
tree96dc46e770de3aa717f74762e50cd7f1f397cbaf /dev-python/gnome-python-base
parentppc/ppc64 stable wrt #338598 (diff)
downloadgentoo-2-634c983f685fd70ce70be3a41d452a2cbca9adc4.tar.gz
gentoo-2-634c983f685fd70ce70be3a41d452a2cbca9adc4.tar.bz2
gentoo-2-634c983f685fd70ce70be3a41d452a2cbca9adc4.zip
Use Python 2.
(Portage version: 2.2.0_alpha26_p15/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gnome-python-base')
-rw-r--r--dev-python/gnome-python-base/ChangeLog6
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild16
2 files changed, 15 insertions, 7 deletions
diff --git a/dev-python/gnome-python-base/ChangeLog b/dev-python/gnome-python-base/ChangeLog
index 294578d92faa..3ac6505dc6ed 100644
--- a/dev-python/gnome-python-base/ChangeLog
+++ b/dev-python/gnome-python-base/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/gnome-python-base
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.38 2011/02/26 13:24:57 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.39 2011/03/11 19:09:57 arfrever Exp $
+
+ 11 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ gnome-python-base-2.28.1.ebuild:
+ Use Python 2.
26 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org>
-gnome-python-base-2.28.0.ebuild:
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild
index 0768f8fcf95c..00a0b967c06d 100644
--- a/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild,v 1.8 2011/01/30 19:42:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild,v 1.9 2011/03/11 19:09:57 arfrever Exp $
GCONF_DEBUG="no"
+EAPI="3"
+PYTHON_DEPEND="2"
-inherit versionator eutils gnome2
+inherit versionator eutils gnome2 python
# This ebuild does nothing -- we just want to get the pkgconfig file installed
@@ -20,10 +22,10 @@ SLOT="2"
RESTRICT="${RESTRICT} test"
# From the gnome-python eclass
-RDEPEND=">=x11-libs/gtk+-2.6
- >=dev-libs/glib-2.6
- >=dev-python/pygtk-2.14.0
- >=dev-python/pygobject-2.17
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.6:2
+ >=dev-python/pygtk-2.14.0:2
+ >=dev-python/pygobject-2.17:2
!<dev-python/gnome-python-2.22.1"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -34,4 +36,6 @@ S="${WORKDIR}/${MY_PN}-${PV}"
pkg_setup() {
G2CONF="${G2CONF} --disable-allbindings"
+ python_set_active_version 2
+ python_pkg_setup
}