summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2011-08-27 14:24:18 +0000
committerMagnus Granberg <zorry@gentoo.org>2011-08-27 14:24:18 +0000
commitddc2edd1000c804842d4aefa94b5e02e13f4b66e (patch)
treec62e30f835e760c1abdb984f5f142c993179b671 /dev-python/git-python/git-python-0.3.2_rc1.ebuild
parentAdd grub2 kcm module for in-kde configuration. (diff)
downloadgentoo-2-ddc2edd1000c804842d4aefa94b5e02e13f4b66e.tar.gz
gentoo-2-ddc2edd1000c804842d4aefa94b5e02e13f4b66e.tar.bz2
gentoo-2-ddc2edd1000c804842d4aefa94b5e02e13f4b66e.zip
Add newer build of git-python
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/git-python/git-python-0.3.2_rc1.ebuild')
-rw-r--r--dev-python/git-python/git-python-0.3.2_rc1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/git-python/git-python-0.3.2_rc1.ebuild b/dev-python/git-python/git-python-0.3.2_rc1.ebuild
new file mode 100644
index 000000000000..5bfd7a004c98
--- /dev/null
+++ b/dev-python/git-python/git-python-0.3.2_rc1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/git-python-0.3.2_rc1.ebuild,v 1.1 2011/08/27 14:24:18 zorry Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="GitPython"
+MY_PV=${PV/_rc/.RC}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="GitPython is a python library used to interact with Git repositories."
+HOMEPAGE="http://gitorious.org/git-python http://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="git"