summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-18 22:54:12 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-18 22:54:12 +0000
commit1f9c839171bc3574867ad68a9988325ff25fe346 (patch)
tree7fce7662e5aef1f41bec09158c03840d2399588d /dev-python/gevent
parentMark arm stable. (diff)
downloadgentoo-2-1f9c839171bc3574867ad68a9988325ff25fe346.tar.gz
gentoo-2-1f9c839171bc3574867ad68a9988325ff25fe346.tar.bz2
gentoo-2-1f9c839171bc3574867ad68a9988325ff25fe346.zip
Remove old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/ChangeLog7
-rw-r--r--dev-python/gevent/gevent-0.13.7.ebuild62
-rw-r--r--dev-python/gevent/gevent-0.13.8.ebuild52
-rw-r--r--dev-python/gevent/gevent-1.0_beta2-r1.ebuild68
-rw-r--r--dev-python/gevent/gevent-1.0_beta2.ebuild73
-rw-r--r--dev-python/gevent/gevent-1.0_rc2.ebuild68
-rw-r--r--dev-python/gevent/gevent-1.0_rc3.ebuild66
7 files changed, 6 insertions, 390 deletions
diff --git a/dev-python/gevent/ChangeLog b/dev-python/gevent/ChangeLog
index b0dda9a3f4ef..e145ad100a9d 100644
--- a/dev-python/gevent/ChangeLog
+++ b/dev-python/gevent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gevent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/ChangeLog,v 1.21 2014/03/18 22:52:27 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/ChangeLog,v 1.22 2014/03/18 22:54:11 radhermit Exp $
+
+ 18 Mar 2014; Tim Harder <radhermit@gentoo.org> -gevent-0.13.7.ebuild,
+ -gevent-0.13.8.ebuild, -gevent-1.0_beta2.ebuild, -gevent-1.0_beta2-r1.ebuild,
+ -gevent-1.0_rc2.ebuild, -gevent-1.0_rc3.ebuild:
+ Remove old.
18 Mar 2014; Tim Harder <radhermit@gentoo.org> gevent-1.0.ebuild:
Mark arm stable.
diff --git a/dev-python/gevent/gevent-0.13.7.ebuild b/dev-python/gevent/gevent-0.13.7.ebuild
deleted file mode 100644
index d3f61a8db9ad..000000000000
--- a/dev-python/gevent/gevent-0.13.7.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/gevent-0.13.7.ebuild,v 1.5 2012/07/17 02:10:30 vapier Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-
-inherit distutils
-
-DESCRIPTION="A Python networking library that uses greenlet to provide synchronous API"
-HOMEPAGE="http://pypi.python.org/pypi/gevent/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/libevent
- dev-python/greenlet"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-# test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite]
-# dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="AUTHORS changelog.rst"
-RESTRICT="test" # long and lot's of failures
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH="$(ls -d ${S}/build-$(PYTHON -f --ABI)/lib.*)" emake html -C doc
- fi
-}
-
-src_test() {
- pushd greentest &> /dev/null
- testing() {
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" testrunner.py
- }
- python_execute_function testing
- popd &> /dev/null
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r doc/_build/html/
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-python/gevent/gevent-0.13.8.ebuild b/dev-python/gevent/gevent-0.13.8.ebuild
deleted file mode 100644
index e9977b460439..000000000000
--- a/dev-python/gevent/gevent-0.13.8.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/gevent-0.13.8.ebuild,v 1.1 2013/05/22 01:31:10 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
-HOMEPAGE="http://gevent.org/ http://pypi.python.org/pypi/gevent/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/libevent
- dev-python/greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-RESTRICT="test"
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- cd greentest || die
- "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( AUTHORS changelog.rst README.rst )
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/gevent/gevent-1.0_beta2-r1.ebuild b/dev-python/gevent/gevent-1.0_beta2-r1.ebuild
deleted file mode 100644
index 632f182a36da..000000000000
--- a/dev-python/gevent/gevent-1.0_beta2-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/gevent-1.0_beta2-r1.ebuild,v 1.1 2013/02/05 23:40:02 mgorny Exp $
-
-EAPI=5
-
-# py2.5 needs http://pypi.python.org/pypi/ssl
-PYTHON_COMPAT=( python{2_6,2_7} )
-PYTHON_REQ_USE="ssl"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PV=${PV/_beta/b}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
-HOMEPAGE="http://code.google.com/p/gevent/ http://pypi.python.org/pypi/gevent/"
-SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/libev
- net-dns/c-ares
- dev-python/greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- rm -rf {libev,c-ares}
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- cd greentest || die
- "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-
- dodoc changelog.rst
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/gevent/gevent-1.0_beta2.ebuild b/dev-python/gevent/gevent-1.0_beta2.ebuild
deleted file mode 100644
index 024fe7a79953..000000000000
--- a/dev-python/gevent/gevent-1.0_beta2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/gevent-1.0_beta2.ebuild,v 1.3 2012/07/17 02:10:30 vapier Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.5 3.* 2.7-pypy-* *-jython"
-PYTHON_USE_WITH="ssl"
-#2.5 needs http://pypi.python.org/pypi/ssl
-
-inherit distutils
-
-MY_PV=${PV/_beta/b}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
-HOMEPAGE="http://code.google.com/p/gevent/ http://pypi.python.org/pypi/gevent/"
-SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/libev
- net-dns/c-ares
- dev-python/greenlet"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="AUTHORS changelog.rst TODO README.rst"
-RESTRICT="test" # long and few failures
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- distutils_src_prepare
- rm -rf {libev,c-ares}
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH="$(ls -d ${S}/build-$(PYTHON -f --ABI)/lib.*)" emake html -C doc
- fi
-}
-
-src_test() {
- pushd greentest &> /dev/null
- testing() {
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" testrunner.py
- }
- python_execute_function testing
- popd &> /dev/null
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r doc/_build/html/
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-python/gevent/gevent-1.0_rc2.ebuild b/dev-python/gevent/gevent-1.0_rc2.ebuild
deleted file mode 100644
index b4c0ae01336a..000000000000
--- a/dev-python/gevent/gevent-1.0_rc2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/gevent-1.0_rc2.ebuild,v 1.2 2013/07/11 21:21:28 vincent Exp $
-
-EAPI=5
-
-# py2.5 needs http://pypi.python.org/pypi/ssl
-PYTHON_COMPAT=( python{2_6,2_7} )
-PYTHON_REQ_USE="ssl"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PV=${PV/_/}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
-HOMEPAGE="http://gevent.org/ http://pypi.python.org/pypi/gevent/"
-SRC_URI="mirror://github/SiteSupport/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/libev
- net-dns/c-ares
- dev-python/greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- rm -rf {libev,c-ares}
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- cd greentest || die
- "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-
- dodoc changelog.rst
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/gevent/gevent-1.0_rc3.ebuild b/dev-python/gevent/gevent-1.0_rc3.ebuild
deleted file mode 100644
index 135398a35a66..000000000000
--- a/dev-python/gevent/gevent-1.0_rc3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/gevent-1.0_rc3.ebuild,v 1.4 2014/02/16 20:07:41 vapier Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-PYTHON_REQ_USE="ssl"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PV=${PV/_/}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
-HOMEPAGE="http://gevent.org/ http://pypi.python.org/pypi/gevent/"
-SRC_URI="https://github.com/surfly/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~ppc ~ppc64 x86"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/libev
- net-dns/c-ares
- dev-python/greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- rm -rf {libev,c-ares}
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- cd greentest || die
- "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-
- dodoc changelog.rst
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}