summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-02 15:40:03 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-02 15:40:03 +0000
commit934135ec9eb1cba2362fcfbd05ae4ed6cd1aee39 (patch)
treec8a932dcd110c106d8c42112babe223dbec39d65 /dev-python/geopy
parentRevbump to add 5.6 support; drop 5.3 (diff)
downloadgentoo-2-934135ec9eb1cba2362fcfbd05ae4ed6cd1aee39.tar.gz
gentoo-2-934135ec9eb1cba2362fcfbd05ae4ed6cd1aee39.tar.bz2
gentoo-2-934135ec9eb1cba2362fcfbd05ae4ed6cd1aee39.zip
bump; add IUSE doc, doc deps and doc build, refine test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/geopy')
-rw-r--r--dev-python/geopy/ChangeLog8
-rw-r--r--dev-python/geopy/geopy-1.1.5.ebuild8
-rw-r--r--dev-python/geopy/geopy-1.3.0.ebuild54
3 files changed, 63 insertions, 7 deletions
diff --git a/dev-python/geopy/ChangeLog b/dev-python/geopy/ChangeLog
index 43074fc60cef..9fd92a5486d9 100644
--- a/dev-python/geopy/ChangeLog
+++ b/dev-python/geopy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/geopy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/ChangeLog,v 1.13 2014/09/19 00:56:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/ChangeLog,v 1.14 2014/10/02 15:40:03 idella4 Exp $
+
+*geopy-1.3.0 (02 Oct 2014)
+
+ 02 Oct 2014; Ian Delaney <idella4@gentoo.org> +geopy-1.3.0.ebuild,
+ geopy-1.1.5.ebuild:
+ bump; add IUSE doc, doc deps and doc build, refine test phase
*geopy-1.1.5 (19 Sep 2014)
diff --git a/dev-python/geopy/geopy-1.1.5.ebuild b/dev-python/geopy/geopy-1.1.5.ebuild
index 4488d6c23597..95292b90ac2f 100644
--- a/dev-python/geopy/geopy-1.1.5.ebuild
+++ b/dev-python/geopy/geopy-1.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/geopy-1.1.5.ebuild,v 1.1 2014/09/19 00:56:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/geopy-1.1.5.ebuild,v 1.2 2014/10/02 15:40:03 idella4 Exp $
EAPI=5
@@ -25,10 +25,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# Usual; required for testsuite
-DISTUTILS_IN_SOURCE_BUILD=1
-
python_test() {
- # intermittent fails or errors caused by an apparent race condition. suite is fine
- nosetests --processes=-1 || die "Tests failed under ${EPYTHON}"
+ nosetests || die "Tests failed under ${EPYTHON}"
}
diff --git a/dev-python/geopy/geopy-1.3.0.ebuild b/dev-python/geopy/geopy-1.3.0.ebuild
new file mode 100644
index 000000000000..a0a906d144ba
--- /dev/null
+++ b/dev-python/geopy/geopy-1.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/geopy-1.3.0.ebuild,v 1.1 2014/10/02 15:40:03 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Geocoding Toolbox for Python"
+HOMEPAGE="http://www.geopy.org/ https://github.com/geopy/geopy"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="test doc yahoo"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="yahoo? ( >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]
+ dev-python/placefinder[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}] )
+ doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/python-docs-2.7.6-r1:2.7 )"
+
+python_prepare_all() {
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" docs/conf.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # intermittent fails or errors caused by an apparent race condition. suite is fine
+ # The setting --processes=-1 invokes this flaw
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}