summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-15 22:44:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-15 22:44:14 +0000
commit394e3fbe100d0df5361e59d5a361d8d4ba09fd57 (patch)
tree4b42c2e1afa954aa9ee16f918a045dc34071e316 /dev-python/flask
parentDelete older ebuilds. (diff)
downloadgentoo-2-394e3fbe100d0df5361e59d5a361d8d4ba09fd57.tar.gz
gentoo-2-394e3fbe100d0df5361e59d5a361d8d4ba09fd57.tar.bz2
gentoo-2-394e3fbe100d0df5361e59d5a361d8d4ba09fd57.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog8
-rw-r--r--dev-python/flask/flask-0.5.2.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 7092ec0ea2c8..28adf1c7248d 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.3 2010/07/06 23:35:52 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.4 2010/07/15 22:44:14 arfrever Exp $
+
+*flask-0.5.2 (15 Jul 2010)
+
+ 15 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -flask-0.4.ebuild, -flask-0.5.1.ebuild, +flask-0.5.2.ebuild:
+ Version bump.
*flask-0.5.1 (06 Jul 2010)
diff --git a/dev-python/flask/flask-0.5.2.ebuild b/dev-python/flask/flask-0.5.2.ebuild
new file mode 100644
index 000000000000..a5ccf962d358
--- /dev/null
+++ b/dev-python/flask/flask-0.5.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.5.2.ebuild,v 1.1 2010/07/15 22:44:14 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="http://pypi.python.org/pypi/Flask"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/jinja-2.4
+ dev-python/setuptools
+ >=dev-python/werkzeug-0.6.1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Delete reference to nonexistent artwork/LICENSE file.
+ sed -e "41,48d" -i docs/license.rst || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" tests/flask_tests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "Installation of examples failed"
+ fi
+}