summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-31 07:42:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-31 07:42:29 +0000
commit9b2f57aa8d972255bd6b9d2b9fb3e44ca4199c05 (patch)
tree43317d94e9cbfb90044e41a337408fc920e58704 /dev-python/flask-script
parentBump (diff)
downloadgentoo-2-9b2f57aa8d972255bd6b9d2b9fb3e44ca4199c05.tar.gz
gentoo-2-9b2f57aa8d972255bd6b9d2b9fb3e44ca4199c05.tar.bz2
gentoo-2-9b2f57aa8d972255bd6b9d2b9fb3e44ca4199c05.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-script')
-rw-r--r--dev-python/flask-script/ChangeLog7
-rw-r--r--dev-python/flask-script/flask-script-0.5.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/flask-script/ChangeLog b/dev-python/flask-script/ChangeLog
index 14b29ae2aa07..04f3dea12eb3 100644
--- a/dev-python/flask-script/ChangeLog
+++ b/dev-python/flask-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-script
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.5 2012/10/29 16:33:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.6 2012/10/31 07:42:29 patrick Exp $
+
+*flask-script-0.5.1 (31 Oct 2012)
+
+ 31 Oct 2012; Patrick Lauer <patrick@gentoo.org> +flask-script-0.5.1.ebuild:
+ Bump
29 Oct 2012; Michał Górny <mgorny@gentoo.org> flask-script-0.3.1.ebuild,
flask-script-0.3.3.ebuild:
diff --git a/dev-python/flask-script/flask-script-0.5.1.ebuild b/dev-python/flask-script/flask-script-0.5.1.ebuild
new file mode 100644
index 000000000000..cf75ae70e5e5
--- /dev/null
+++ b/dev-python/flask-script/flask-script-0.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.5.1.ebuild,v 1.1 2012/10/31 07:42:29 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Flask-Script"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flask support for writing external scripts."
+HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/flask
+ virtual/python-argparse"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="flaskext/script.py"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}