summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-06-23 09:24:24 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-06-23 09:24:24 +0000
commitff9d884a684f9762325239237e3e87db16c9efec (patch)
tree711fbecd6b69c988192d251c80d958c2076b546e /dev-python/feedparser
parentVersion bump. (diff)
downloadgentoo-2-ff9d884a684f9762325239237e3e87db16c9efec.tar.gz
gentoo-2-ff9d884a684f9762325239237e3e87db16c9efec.tar.bz2
gentoo-2-ff9d884a684f9762325239237e3e87db16c9efec.zip
Remove old.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python/feedparser')
-rw-r--r--dev-python/feedparser/ChangeLog6
-rw-r--r--dev-python/feedparser/feedparser-5.1.3-r1.ebuild40
-rw-r--r--dev-python/feedparser/feedparser-5.1.3.ebuild53
3 files changed, 5 insertions, 94 deletions
diff --git a/dev-python/feedparser/ChangeLog b/dev-python/feedparser/ChangeLog
index 63d465b22d73..27eaadac5e32 100644
--- a/dev-python/feedparser/ChangeLog
+++ b/dev-python/feedparser/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/feedparser
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.64 2015/06/02 05:10:35 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.65 2015/06/23 09:24:24 mrueg Exp $
+
+ 23 Jun 2015; Manuel Rüger <mrueg@gentoo.org> -feedparser-5.1.3-r1.ebuild,
+ -feedparser-5.1.3.ebuild:
+ Remove old.
02 Jun 2015; Jack Morgan <jmorgan@gentoo.org> feedparser-5.1.3-r2.ebuild:
sparc stable wrt bug #540290
diff --git a/dev-python/feedparser/feedparser-5.1.3-r1.ebuild b/dev-python/feedparser/feedparser-5.1.3-r1.ebuild
deleted file mode 100644
index 0fc03c05d339..000000000000
--- a/dev-python/feedparser/feedparser-5.1.3-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.1.3-r1.ebuild,v 1.10 2015/04/08 08:05:29 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Parse RSS and Atom feeds in Python"
-HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-# sgmllib is licensed under PSF-2.
-LICENSE="BSD-2 PSF-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-# Tests have issues with chardet installed, and are just kind of buggy.
-RESTRICT="test"
-
-python_prepare_all() {
- mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die
- epatch "${FILESDIR}/${PN}-5.1-sgmllib.patch"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cp feedparser/feedparsertest.py "${BUILD_DIR}" || die
- ln -s "${S}/feedparser/tests" "${BUILD_DIR}/tests" || die
- cd "${BUILD_DIR}" || die
- if [[ ${EPYTHON} == python3* ]]; then
- 2to3 --no-diffs -w -n feedparsertest.py || die
- fi
- "${PYTHON}" feedparsertest.py || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/feedparser/feedparser-5.1.3.ebuild b/dev-python/feedparser/feedparser-5.1.3.ebuild
deleted file mode 100644
index fa194839ea7a..000000000000
--- a/dev-python/feedparser/feedparser-5.1.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.1.3.ebuild,v 1.1 2012/12/09 21:45:45 rafaelmartins Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
-
-inherit distutils eutils
-
-DESCRIPTION="Parse RSS and Atom feeds in Python"
-HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-# sgmllib is licensed under PSF-2.
-LICENSE="BSD-2 PSF-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="feedparser.py _feedparser_sgmllib.py"
-
-src_prepare() {
- mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die "Renaming sgmllib3.py failed"
- epatch "${FILESDIR}/${PN}-5.1-sgmllib.patch"
-
- sed -e "/import feedparser/isys.path.insert(0, '../build/lib')" -i feedparser/feedparsertest.py
-
- distutils_src_prepare
-
- preparation() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- 2to3-${PYTHON_ABI} -nw --no-diffs feedparser/feedparsertest.py
- else
- # Avoid SyntaxErrors with Python 2.
- echo "raise ImportError" > feedparser/_feedparser_sgmllib.py
- fi
- }
- python_execute_function -s preparation
-}
-
-src_test() {
- testing() {
- cd feedparser || return 1
- "$(PYTHON)" feedparsertest.py
- }
- python_execute_function -s testing
-}