summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-20 12:29:38 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-20 12:29:38 +0000
commit810e278cb3046658953d53a7bcb8f32b76937913 (patch)
treeb67975d7c7e3224eeb53cbec5acba12709a88609 /dev-python/feedparser
parentrm old (diff)
downloadgentoo-2-810e278cb3046658953d53a7bcb8f32b76937913.tar.gz
gentoo-2-810e278cb3046658953d53a7bcb8f32b76937913.tar.bz2
gentoo-2-810e278cb3046658953d53a7bcb8f32b76937913.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/feedparser')
-rw-r--r--dev-python/feedparser/ChangeLog6
-rw-r--r--dev-python/feedparser/feedparser-5.0.1.ebuild61
-rw-r--r--dev-python/feedparser/feedparser-5.1.1.ebuild53
-rw-r--r--dev-python/feedparser/feedparser-5.1.2.ebuild53
-rw-r--r--dev-python/feedparser/feedparser-5.1.ebuild53
5 files changed, 5 insertions, 221 deletions
diff --git a/dev-python/feedparser/ChangeLog b/dev-python/feedparser/ChangeLog
index 426bd29f036b..2dedb8b2cc90 100644
--- a/dev-python/feedparser/ChangeLog
+++ b/dev-python/feedparser/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/feedparser
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.55 2014/12/13 16:07:19 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.56 2014/12/20 12:29:38 idella4 Exp $
+
+ 20 Dec 2014; Ian Delaney <idella4@gentoo.org> -feedparser-5.0.1.ebuild,
+ -feedparser-5.1.1.ebuild, -feedparser-5.1.2.ebuild, -feedparser-5.1.ebuild:
+ rm old
13 Dec 2014; Sebastian Pipping <sping@gentoo.org> feedparser-5.1.3-r2.ebuild:
Drop Python 3.2 support
diff --git a/dev-python/feedparser/feedparser-5.0.1.ebuild b/dev-python/feedparser/feedparser-5.0.1.ebuild
deleted file mode 100644
index 1600881de7a3..000000000000
--- a/dev-python/feedparser/feedparser-5.0.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.0.1.ebuild,v 1.9 2011/11/16 19:10:07 hwoarang Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-# 877 errors with Python 3.
-PYTHON_TESTS_RESTRICTED_ABIS="3.* *-jython"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
-
-inherit distutils eutils
-
-DESCRIPTION="Parse RSS and Atom feeds in Python"
-HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-# sgmllib is licensed under PSF-2.
-LICENSE="BSD-2 PSF-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-DOCS="LICENSE NEWS"
-PYTHON_MODNAME="feedparser.py _feedparser_sgmllib.py"
-
-src_prepare() {
- mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die "Renaming sgmllib3.py failed"
- epatch "${FILESDIR}/${P}-sgmllib.patch"
-
- distutils_src_prepare
-
- preparation() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- 2to3-${PYTHON_ABI} -nw --no-diffs feedparser/{feedparser.py,feedparsertest.py} || return 1
- else
- # Avoid SyntaxErrors with Python 2.
- echo "raise ImportError" > feedparser/_feedparser_sgmllib.py || return 1
- fi
- }
- python_execute_function -s preparation
-}
-
-src_compile() {
- PYTHONPATH="feedparser" distutils_src_compile
-}
-
-src_test() {
- testing() {
- cd feedparser || return 1
- PYTHONPATH="." "$(PYTHON)" feedparsertest.py
- }
- python_execute_function -s testing
-}
-
-src_install() {
- PYTHONPATH="feedparser" distutils_src_install
-}
diff --git a/dev-python/feedparser/feedparser-5.1.1.ebuild b/dev-python/feedparser/feedparser-5.1.1.ebuild
deleted file mode 100644
index 78b4b63fe43a..000000000000
--- a/dev-python/feedparser/feedparser-5.1.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.1.1.ebuild,v 1.1 2012/03/20 17:54:19 sping Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
-
-inherit distutils eutils
-
-DESCRIPTION="Parse RSS and Atom feeds in Python"
-HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-# sgmllib is licensed under PSF-2.
-LICENSE="BSD-2 PSF-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="feedparser.py _feedparser_sgmllib.py"
-
-src_prepare() {
- mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die "Renaming sgmllib3.py failed"
- epatch "${FILESDIR}/${PN}-5.1-sgmllib.patch"
-
- sed -e "/import feedparser/isys.path.insert(0, '../build/lib')" -i feedparser/feedparsertest.py
-
- distutils_src_prepare
-
- preparation() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- 2to3-${PYTHON_ABI} -nw --no-diffs feedparser/feedparsertest.py
- else
- # Avoid SyntaxErrors with Python 2.
- echo "raise ImportError" > feedparser/_feedparser_sgmllib.py
- fi
- }
- python_execute_function -s preparation
-}
-
-src_test() {
- testing() {
- cd feedparser || return 1
- "$(PYTHON)" feedparsertest.py
- }
- python_execute_function -s testing
-}
diff --git a/dev-python/feedparser/feedparser-5.1.2.ebuild b/dev-python/feedparser/feedparser-5.1.2.ebuild
deleted file mode 100644
index 46ee33f5cd94..000000000000
--- a/dev-python/feedparser/feedparser-5.1.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.1.2.ebuild,v 1.6 2012/06/08 18:10:10 ranger Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
-
-inherit distutils eutils
-
-DESCRIPTION="Parse RSS and Atom feeds in Python"
-HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-# sgmllib is licensed under PSF-2.
-LICENSE="BSD-2 PSF-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="feedparser.py _feedparser_sgmllib.py"
-
-src_prepare() {
- mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die "Renaming sgmllib3.py failed"
- epatch "${FILESDIR}/${PN}-5.1-sgmllib.patch"
-
- sed -e "/import feedparser/isys.path.insert(0, '../build/lib')" -i feedparser/feedparsertest.py
-
- distutils_src_prepare
-
- preparation() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- 2to3-${PYTHON_ABI} -nw --no-diffs feedparser/feedparsertest.py
- else
- # Avoid SyntaxErrors with Python 2.
- echo "raise ImportError" > feedparser/_feedparser_sgmllib.py
- fi
- }
- python_execute_function -s preparation
-}
-
-src_test() {
- testing() {
- cd feedparser || return 1
- "$(PYTHON)" feedparsertest.py
- }
- python_execute_function -s testing
-}
diff --git a/dev-python/feedparser/feedparser-5.1.ebuild b/dev-python/feedparser/feedparser-5.1.ebuild
deleted file mode 100644
index 00b36f377834..000000000000
--- a/dev-python/feedparser/feedparser-5.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.1.ebuild,v 1.1 2012/01/03 04:18:13 floppym Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
-
-inherit distutils eutils
-
-DESCRIPTION="Parse RSS and Atom feeds in Python"
-HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-# sgmllib is licensed under PSF-2.
-LICENSE="BSD-2 PSF-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="feedparser.py _feedparser_sgmllib.py"
-
-src_prepare() {
- mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die "Renaming sgmllib3.py failed"
- epatch "${FILESDIR}/${P}-sgmllib.patch"
-
- sed -e "/import feedparser/isys.path.insert(0, '../build/lib')" -i feedparser/feedparsertest.py
-
- distutils_src_prepare
-
- preparation() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- 2to3-${PYTHON_ABI} -nw --no-diffs feedparser/feedparsertest.py
- else
- # Avoid SyntaxErrors with Python 2.
- echo "raise ImportError" > feedparser/_feedparser_sgmllib.py
- fi
- }
- python_execute_function -s preparation
-}
-
-src_test() {
- testing() {
- cd feedparser || return 1
- "$(PYTHON)" feedparsertest.py
- }
- python_execute_function -s testing
-}