summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-10 02:10:02 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-10 02:10:02 +0000
commit1e8aada124410ee088c84a08fe8b5088b0a73c86 (patch)
treebb51fed0390ac3f9bc4786525d71184e4c93c513 /dev-python/feedparser
parentadd test using version from #404371 (diff)
downloadgentoo-2-1e8aada124410ee088c84a08fe8b5088b0a73c86.tar.gz
gentoo-2-1e8aada124410ee088c84a08fe8b5088b0a73c86.tar.bz2
gentoo-2-1e8aada124410ee088c84a08fe8b5088b0a73c86.zip
Convert to distutils-r1.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/feedparser')
-rw-r--r--dev-python/feedparser/ChangeLog10
-rw-r--r--dev-python/feedparser/feedparser-5.1.3-r1.ebuild40
2 files changed, 47 insertions, 3 deletions
diff --git a/dev-python/feedparser/ChangeLog b/dev-python/feedparser/ChangeLog
index 1c5074ba9eeb..dcfd921075da 100644
--- a/dev-python/feedparser/ChangeLog
+++ b/dev-python/feedparser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/feedparser
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.41 2012/12/09 21:45:45 rafaelmartins Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.42 2013/02/10 02:10:02 floppym Exp $
+
+*feedparser-5.1.3-r1 (10 Feb 2013)
+
+ 10 Feb 2013; Mike Gilbert <floppym@gentoo.org> +feedparser-5.1.3-r1.ebuild:
+ Convert to distutils-r1.
*feedparser-5.1.3 (09 Dec 2012)
@@ -157,4 +162,3 @@
03 Nov 2005; Alastair Tse <liquidx@gentoo.org> +metadata.xml,
+feedparser-3.3.ebuild:
initial commit (ebuild thanks to Fabian Groffen #69803)
-
diff --git a/dev-python/feedparser/feedparser-5.1.3-r1.ebuild b/dev-python/feedparser/feedparser-5.1.3-r1.ebuild
new file mode 100644
index 000000000000..e03b6266657e
--- /dev/null
+++ b/dev-python/feedparser/feedparser-5.1.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.1.3-r1.ebuild,v 1.1 2013/02/10 02:10:02 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_{5,6,7},3_{1,2,3}} pypy{1_9,2_0} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Parse RSS and Atom feeds in Python"
+HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+# sgmllib is licensed under PSF-2.
+LICENSE="BSD-2 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+# Tests have issues with chardet installed, and are just kind of buggy.
+RESTRICT="test"
+
+python_prepare_all() {
+ mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die
+ epatch "${FILESDIR}/${PN}-5.1-sgmllib.patch"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp feedparser/feedparsertest.py "${BUILD_DIR}" || die
+ ln -s "${S}/feedparser/tests" "${BUILD_DIR}/tests" || die
+ cd "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 --no-diffs -w -n feedparsertest.py || die
+ fi
+ "${PYTHON}" feedparsertest.py || die "Testing failed with ${EPYTHON}"
+}