summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-15 18:44:15 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-15 18:44:15 +0000
commit4bb44fe4d84167d0954ca39b2ffaf63e097de15a (patch)
tree302fb479b95a07b5b244582df49e0395e357a71e /dev-python/fabric
parentVersion bump. (diff)
downloadgentoo-2-4bb44fe4d84167d0954ca39b2ffaf63e097de15a.tar.gz
gentoo-2-4bb44fe4d84167d0954ca39b2ffaf63e097de15a.tar.bz2
gentoo-2-4bb44fe4d84167d0954ca39b2ffaf63e097de15a.zip
Use vcs-snapshot.eclass to avoid variable shuffling, depend on sphinx for docs, fix double html in docs' install path, drop unnecessary die
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/fabric')
-rw-r--r--dev-python/fabric/ChangeLog9
-rw-r--r--dev-python/fabric/fabric-1.4.2-r1.ebuild (renamed from dev-python/fabric/fabric-1.4.2.ebuild)19
2 files changed, 15 insertions, 13 deletions
diff --git a/dev-python/fabric/ChangeLog b/dev-python/fabric/ChangeLog
index 2f77d8d74195..2e0084468bbd 100644
--- a/dev-python/fabric/ChangeLog
+++ b/dev-python/fabric/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/fabric
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.22 2012/05/10 23:31:35 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.23 2012/05/15 18:44:15 xarthisius Exp $
+
+*fabric-1.4.2-r1 (15 May 2012)
+
+ 15 May 2012; Kacper Kowalik <xarthisius@gentoo.org> +fabric-1.4.2-r1.ebuild,
+ -fabric-1.4.2.ebuild:
+ Use vcs-snapshot.eclass to avoid variable shuffling, depend on sphinx for
+ docs, fix double html in docs' install path, drop unnecessary die
*fabric-1.4.2 (10 May 2012)
diff --git a/dev-python/fabric/fabric-1.4.2.ebuild b/dev-python/fabric/fabric-1.4.2-r1.ebuild
index 104655d4c597..0074809d725f 100644
--- a/dev-python/fabric/fabric-1.4.2.ebuild
+++ b/dev-python/fabric/fabric-1.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.4.2.ebuild,v 1.1 2012/05/10 23:31:35 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.4.2-r1.ebuild,v 1.1 2012/05/15 18:44:15 xarthisius Exp $
EAPI="4"
PYTHON_DEPEND="2:2.5"
@@ -8,15 +8,11 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
#DISTUTILS_SRC_TEST="nosetests"
-inherit distutils eutils
-
-MY_PN="Fabric"
-MY_P="${MY_PN}-${PV}"
-GIT_HASH_TAG="3a4006e"
+inherit distutils eutils vcs-snapshot
DESCRIPTION="Fabric is a simple, Pythonic tool for remote execution and deployment."
HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
-SRC_URI="http://github.com/${PN}/${PN}/tarball/${PV} -> ${MY_P}.tar.gz"
+SRC_URI="http://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -25,14 +21,13 @@ IUSE="doc"
RDEPEND=">=dev-python/ssh-1.7.14"
DEPEND="${RDEPEND}
- dev-python/setuptools"
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
# test? ( dev-python/fudge )"
# Tests broken.
RESTRICT="test"
-S="${WORKDIR}/${PN}-${PN}-${GIT_HASH_TAG}"
-
PYTHON_MODULES="fabfile fabric"
src_prepare() {
@@ -44,7 +39,7 @@ src_compile() {
distutils_src_compile
if use doc; then
- emake -C docs html || die "Couldn't make docs"
+ emake -C docs html
fi
}
@@ -52,6 +47,6 @@ src_install() {
distutils_src_install
if use doc; then
- dohtml -r docs/_build/html
+ dohtml -r docs/_build/html/
fi
}