summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-02-26 13:27:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-02-26 13:27:05 +0000
commita366f3fc7ea55ef682557a1f05a7bbcf6b63034f (patch)
tree80d60eabcba0fd9d728294fb4c85fa690d4d7850 /dev-python/egg-python
parentAdd missing eclass variables for proper python-updater behavior, bug #344833.... (diff)
downloadgentoo-2-a366f3fc7ea55ef682557a1f05a7bbcf6b63034f.tar.gz
gentoo-2-a366f3fc7ea55ef682557a1f05a7bbcf6b63034f.tar.bz2
gentoo-2-a366f3fc7ea55ef682557a1f05a7bbcf6b63034f.zip
Add missing eclass variables for proper python-updater behavior, bug #344833. Clean up old revision.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/egg-python')
-rw-r--r--dev-python/egg-python/ChangeLog7
-rw-r--r--dev-python/egg-python/egg-python-2.19.1.ebuild35
-rw-r--r--dev-python/egg-python/egg-python-2.25.3.ebuild6
3 files changed, 11 insertions, 37 deletions
diff --git a/dev-python/egg-python/ChangeLog b/dev-python/egg-python/ChangeLog
index 25a6ae69086c..2b19b7d4861b 100644
--- a/dev-python/egg-python/ChangeLog
+++ b/dev-python/egg-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/egg-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/ChangeLog,v 1.20 2011/01/30 18:19:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/ChangeLog,v 1.21 2011/02/26 13:27:05 eva Exp $
+
+ 26 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ -egg-python-2.19.1.ebuild, egg-python-2.25.3.ebuild:
+ Add missing eclass variables for proper python-updater behavior, bug #344833.
+ Clean up old revision.
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> egg-python-2.25.3.ebuild:
alpha/ia64/sparc stable wrt #348987
diff --git a/dev-python/egg-python/egg-python-2.19.1.ebuild b/dev-python/egg-python/egg-python-2.19.1.ebuild
deleted file mode 100644
index 1cb8655eb248..000000000000
--- a/dev-python/egg-python/egg-python-2.19.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/egg-python-2.19.1.ebuild,v 1.15 2010/07/20 16:37:33 jer Exp $
-
-EAPI="2"
-
-# We don't support the egg.recent bindings that are also provided - they are
-# deprecated, have deps we don't really want and there are no users in-tree.
-G_PY_PN="gnome-python-extras"
-G_PY_BINDINGS="eggtray"
-
-inherit gnome-python-common
-
-PVP="$(get_version_component_range 1-2)"
-SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2
- mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
-
-DESCRIPTION="EggTrayIcon bindings for Python"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="examples"
-
-RDEPEND=">=dev-python/libbonobo-python-2.22.1
- >=dev-python/libgnome-python-2.22.1"
-DEPEND="${RDEPEND}"
-
-EXAMPLES="examples/egg/tray*"
-
-src_prepare() {
- epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
- eautoreconf
-
- gnome-python-common_src_prepare
-}
diff --git a/dev-python/egg-python/egg-python-2.25.3.ebuild b/dev-python/egg-python/egg-python-2.25.3.ebuild
index 3dac0230d24e..c22f2e0950f8 100644
--- a/dev-python/egg-python/egg-python-2.25.3.ebuild
+++ b/dev-python/egg-python/egg-python-2.25.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/egg-python-2.25.3.ebuild,v 1.7 2011/01/30 18:19:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/egg-python-2.25.3.ebuild,v 1.8 2011/02/26 13:27:05 eva Exp $
EAPI="2"
@@ -9,6 +9,10 @@ EAPI="2"
G_PY_PN="gnome-python-extras"
G_PY_BINDINGS="eggtray"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit gnome-python-common
PVP="$(get_version_component_range 1-2)"