summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-27 01:04:07 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-27 01:04:07 +0000
commit679e9ae399fc4df9370f27920374aad2e8693981 (patch)
tree1894e94a2760e052076f3467e446f684624347e8 /dev-python/egg-python
parentStable for HPPA (bug #241636). (diff)
downloadgentoo-2-679e9ae399fc4df9370f27920374aad2e8693981.tar.gz
gentoo-2-679e9ae399fc4df9370f27920374aad2e8693981.tar.bz2
gentoo-2-679e9ae399fc4df9370f27920374aad2e8693981.zip
Use python_need_rebuild.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-python/egg-python')
-rw-r--r--dev-python/egg-python/ChangeLog5
-rw-r--r--dev-python/egg-python/egg-python-2.19.1.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/egg-python/ChangeLog b/dev-python/egg-python/ChangeLog
index 87111070bc63..c4a270b988be 100644
--- a/dev-python/egg-python/ChangeLog
+++ b/dev-python/egg-python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/egg-python
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/ChangeLog,v 1.1 2008/10/16 22:49:31 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/ChangeLog,v 1.2 2008/10/27 01:04:07 hawking Exp $
+
+ 27 Oct 2008; Ali Polatel <hawking@gentoo.org> egg-python-2.19.1.ebuild:
+ Use python_need_rebuild.
*egg-python-2.19.1 (16 Oct 2008)
diff --git a/dev-python/egg-python/egg-python-2.19.1.ebuild b/dev-python/egg-python/egg-python-2.19.1.ebuild
index 093c50b35a6f..82e47004f3f3 100644
--- a/dev-python/egg-python/egg-python-2.19.1.ebuild
+++ b/dev-python/egg-python/egg-python-2.19.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/egg-python-2.19.1.ebuild,v 1.1 2008/10/16 22:49:31 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egg-python/egg-python-2.19.1.ebuild,v 1.2 2008/10/27 01:04:07 hawking Exp $
# We don't support the egg.recent bindings that are also provided - they are
# deprecated, have deps we don't really want and there are no users in-tree.
G_PY_PN="gnome-python-extras"
G_PY_BINDINGS="eggtray"
-inherit gnome-python-common
+inherit gnome-python-common python
PVP="$(get_version_component_range 1-2)"
SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2
@@ -30,3 +30,8 @@ src_unpack() {
epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
eautoreconf
}
+
+src_install() {
+ python_need_rebuild
+ gnome-python-common_src_install
+}