summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2013-06-27 22:19:41 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2013-06-27 22:19:41 +0000
commitef31b9c7b13f8f5a727c4048c79e93373bc52462 (patch)
treec248dd550a7adc3b59ad6ac461fe1647f85fdec5 /dev-python/edpwd/edpwd-0.0.7.ebuild
parentUse filename pointers to give a meaningful name to the tarball. (diff)
downloadgentoo-2-ef31b9c7b13f8f5a727c4048c79e93373bc52462.tar.gz
gentoo-2-ef31b9c7b13f8f5a727c4048c79e93373bc52462.tar.bz2
gentoo-2-ef31b9c7b13f8f5a727c4048c79e93373bc52462.zip
version bump, use `python setup.py test` to run the tests
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x57DC0078)
Diffstat (limited to 'dev-python/edpwd/edpwd-0.0.7.ebuild')
-rw-r--r--dev-python/edpwd/edpwd-0.0.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/edpwd/edpwd-0.0.7.ebuild b/dev-python/edpwd/edpwd-0.0.7.ebuild
new file mode 100644
index 000000000000..39f2cf5e2a8e
--- /dev/null
+++ b/dev-python/edpwd/edpwd-0.0.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/edpwd/edpwd-0.0.7.ebuild,v 1.1 2013/06/27 22:19:41 tampakrap Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Encrypt/Decrypt Password Library that wraps up Blowfish"
+HOMEPAGE="http://pypi.python.org/pypi/edpwd/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/setuptools-0.6.30[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
+
+python_test() {
+ set -- "${PYTHON}" setup.py test
+ echo "${@}"
+ "${@}" || die "Tests failed with ${EPYTHON}"
+}