summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-20 02:58:05 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-20 02:58:05 +0000
commitcbcb8e159041c961f311bf20f7f6129d88c0da00 (patch)
tree5a7cc7828422dbb0c5b5eaf85622f4c9311e2afc /dev-python/dulwich
parentminor correction to Changelog (diff)
downloadgentoo-2-cbcb8e159041c961f311bf20f7f6129d88c0da00.tar.gz
gentoo-2-cbcb8e159041c961f311bf20f7f6129d88c0da00.tar.bz2
gentoo-2-cbcb8e159041c961f311bf20f7f6129d88c0da00.zip
drop py2.6 pypy2_0, add IUSE examples, dep for tests, updrade test phase, closes Bug #513392
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog8
-rw-r--r--dev-python/dulwich/dulwich-0.9.7.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 3ec278585e52..ef668173b61c 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.78 2014/03/31 21:16:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.79 2014/06/20 02:58:05 idella4 Exp $
+
+*dulwich-0.9.7 (20 Jun 2014)
+
+ 20 Jun 2014; Ian Delaney <idella4@gentoo.org> +dulwich-0.9.7.ebuild:
+ drop py2.6 pypy2_0, add IUSE examples, dep for tests, updrade test phase,
+ closes Bug #513392
31 Mar 2014; Michał Górny <mgorny@gentoo.org> dulwich-0.9.4.ebuild,
dulwich-0.9.5.ebuild:
diff --git a/dev-python/dulwich/dulwich-0.9.7.ebuild b/dev-python/dulwich/dulwich-0.9.7.ebuild
new file mode 100644
index 000000000000..8ffb06c05ab1
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.9.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.9.7.ebuild,v 1.1 2014/06/20 02:58:05 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="https://github.com/jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/gevent[$(python_gen_usedep python2_7)]
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/jelmer/dulwich/issues/196
+ if [[ "${EPYTHON}" == pypy ]]; then
+ "${PYTHON}" -m unittest dulwich.tests.test_suite || die "Tests failed under pypy"
+ else
+ emake check
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}