summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-23 01:24:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-23 01:24:20 +0000
commit6402bec469b5bef54b34ac61d7f2ebd571d3e776 (patch)
treee5e4122f0b6c5bbe95b951829124ec067d576fe1 /dev-python/dulwich
parentold (diff)
downloadgentoo-2-6402bec469b5bef54b34ac61d7f2ebd571d3e776.tar.gz
gentoo-2-6402bec469b5bef54b34ac61d7f2ebd571d3e776.tar.bz2
gentoo-2-6402bec469b5bef54b34ac61d7f2ebd571d3e776.zip
Add src_test().
(Portage version: 14874-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog6
-rw-r--r--dev-python/dulwich/dulwich-0.4.0.ebuild18
2 files changed, 18 insertions, 6 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 823495230abd..96febd4de22e 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.1 2009/10/20 08:55:33 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.2 2009/11/23 01:24:20 arfrever Exp $
+
+ 23 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ dulwich-0.4.0.ebuild:
+ Add src_test().
*dulwich-0.4.0 (20 Oct 2009)
diff --git a/dev-python/dulwich/dulwich-0.4.0.ebuild b/dev-python/dulwich/dulwich-0.4.0.ebuild
index 3d5b5cb9878f..f5a11e980c3f 100644
--- a/dev-python/dulwich/dulwich-0.4.0.ebuild
+++ b/dev-python/dulwich/dulwich-0.4.0.ebuild
@@ -1,20 +1,28 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.4.0.ebuild,v 1.1 2009/10/20 08:55:33 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.4.0.ebuild,v 1.2 2009/11/23 01:24:20 arfrever Exp $
+EAPI="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
-HOMEPAGE="http://samba.org/~jelmer/dulwich/"
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-DEPEND=""
+DEPEND="test? ( dev-python/nose )"
RDEPEND=""
RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}