summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-17 20:44:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-17 20:44:29 +0000
commit276cb4dbdf2a8ac8138b1e1e0b1c397d7251b987 (patch)
tree7d7239f0fbe28d8c083830e34f287495f33a5485 /dev-python/dulwich
parentVersion bump. (diff)
downloadgentoo-2-276cb4dbdf2a8ac8138b1e1e0b1c397d7251b987.tar.gz
gentoo-2-276cb4dbdf2a8ac8138b1e1e0b1c397d7251b987.tar.bz2
gentoo-2-276cb4dbdf2a8ac8138b1e1e0b1c397d7251b987.zip
Version bump.
(Portage version: 2.2_rc97_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog8
-rw-r--r--dev-python/dulwich/dulwich-0.6.2.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 6300f4afbbd6..dc1b1bf7c501 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.18 2010/09/19 23:31:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.19 2010/10/17 20:44:29 arfrever Exp $
+
+*dulwich-0.6.2 (17 Oct 2010)
+
+ 17 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +dulwich-0.6.2.ebuild:
+ Version bump.
19 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-dulwich-0.6.0.ebuild:
diff --git a/dev-python/dulwich/dulwich-0.6.2.ebuild b/dev-python/dulwich/dulwich-0.6.2.ebuild
new file mode 100644
index 000000000000..0690e62ff731
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.6.2.ebuild,v 1.1 2010/10/17 20:44:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}