summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-18 06:36:50 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-18 06:36:50 +0000
commitdfc67327e01f5505c79a8764cbf87c798a544fb7 (patch)
tree86de9d9411f25bb0b446976408b905137d1f46e2 /dev-python/dugong
parentAllowed user patching. (diff)
downloadgentoo-2-dfc67327e01f5505c79a8764cbf87c798a544fb7.tar.gz
gentoo-2-dfc67327e01f5505c79a8764cbf87c798a544fb7.tar.bz2
gentoo-2-dfc67327e01f5505c79a8764cbf87c798a544fb7.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/dugong')
-rw-r--r--dev-python/dugong/ChangeLog7
-rw-r--r--dev-python/dugong/dugong-3.3.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/dugong/ChangeLog b/dev-python/dugong/ChangeLog
index fbae0a56c80c..6cb063ae0fe8 100644
--- a/dev-python/dugong/ChangeLog
+++ b/dev-python/dugong/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dugong
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/ChangeLog,v 1.6 2014/08/12 14:06:27 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/ChangeLog,v 1.7 2014/08/18 06:36:50 idella4 Exp $
+
+*dugong-3.3 (18 Aug 2014)
+
+ 18 Aug 2014; Ian Delaney <idella4@gentoo.org> +dugong-3.3.ebuild:
+ bump
12 Aug 2014; Ian Delaney <idella4@gentoo.org> +files/3.2-aborted_write.patch,
+files/3.2-extract_links.patch, +files/3.2-timeout.patch, dugong-3.2.ebuild:
diff --git a/dev-python/dugong/dugong-3.3.ebuild b/dev-python/dugong/dugong-3.3.ebuild
new file mode 100644
index 000000000000..04185e63c1bd
--- /dev/null
+++ b/dev-python/dugong/dugong-3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/dugong-3.3.ebuild,v 1.1 2014/08/18 06:36:50 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/3.2-extract_links.patch
+ "${FILESDIR}"/3.2-timeout.patch
+ "${FILESDIR}"/3.2-aborted_write.patch )
+
+python_test() {
+ # https://bitbucket.org/nikratio/python-dugong/issue/12
+ einfo "Test suite can take several minutes to complete"
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}