summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-03-14 19:38:09 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-03-14 19:38:09 +0000
commit377062ede2b8a24d9980f8ead6d4a6789c009c1c (patch)
treead25a66b26f60f5540c1eb126511826e12953440 /dev-python/docutils/files
parentStable on sparc wrt #84704 (diff)
downloadgentoo-2-377062ede2b8a24d9980f8ead6d4a6789c009c1c.tar.gz
gentoo-2-377062ede2b8a24d9980f8ead6d4a6789c009c1c.tar.bz2
gentoo-2-377062ede2b8a24d9980f8ead6d4a6789c009c1c.zip
Fixed python 2.4 DEPENDs. Added src_test to 0.3.7. Marked 0.3.5 x86 bug# 79635
(Portage version: 2.0.51.18)
Diffstat (limited to 'dev-python/docutils/files')
-rw-r--r--dev-python/docutils/files/digest-docutils-0.3.72
-rw-r--r--dev-python/docutils/files/docutils-0.3.7-extramodules.patch32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/docutils/files/digest-docutils-0.3.7 b/dev-python/docutils/files/digest-docutils-0.3.7
new file mode 100644
index 000000000000..394e2d08763c
--- /dev/null
+++ b/dev-python/docutils/files/digest-docutils-0.3.7
@@ -0,0 +1,2 @@
+MD5 fdd192d62bf5aebac6258a7ae8af5123 docutils-0.3.7.tar.gz 625719
+MD5 e129dda1ed953ef15fd54c7bc466b5a1 glep-0.3.7.tbz2 5055
diff --git a/dev-python/docutils/files/docutils-0.3.7-extramodules.patch b/dev-python/docutils/files/docutils-0.3.7-extramodules.patch
new file mode 100644
index 000000000000..f5701d681cbe
--- /dev/null
+++ b/dev-python/docutils/files/docutils-0.3.7-extramodules.patch
@@ -0,0 +1,32 @@
+--- docutils-0.3.7/setup.py 2004-07-29 16:57:28.000000000 +0200
++++ docutils-0.3.7/setup.py.new 2004-09-23 10:06:06.263010624 +0200
+@@ -82,20 +82,15 @@
+ List of (module name, minimum __version__ string, [attribute names])."""
+
+ def get_extras():
+- extras = []
+- for module_name, version, attributes in extra_modules:
+- try:
+- module = __import__(module_name)
+- if version and module.__version__ < version:
+- raise ValueError
+- for attribute in attributes or []:
+- getattr(module, attribute)
+- print ('"%s" module already present; ignoring extras/%s.py.'
+- % (module_name, module_name))
+- except (ImportError, AttributeError, ValueError):
+- extras.append(module_name)
+- return extras
+-
++ # old method does not work for upgrading/downgrading docutils.
++ # so we use a simple rule, 'optparse' and 'textwrap' are not installed
++ # for >=python-2.3
++
++ pyver = sys.version_info
++ if pyver[0] == 2 and pyver[1] > 2:
++ return ["roman"]
++ else:
++ return ["optparse","textwrap","roman"]
+
+ class dual_build_py(build_py):
+