summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-18 14:58:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-18 14:58:48 +0000
commitb8005192d3e5fc143b88147c1af377c4e12dc87c (patch)
tree64f34492a124a079e8b24ce268d0ec1f91e05bb6 /dev-python/django
parentDelete older ebuilds. (diff)
downloadgentoo-2-b8005192d3e5fc143b88147c1af377c4e12dc87c.tar.gz
gentoo-2-b8005192d3e5fc143b88147c1af377c4e12dc87c.tar.bz2
gentoo-2-b8005192d3e5fc143b88147c1af377c4e12dc87c.zip
Rename "sqlite3" USE flag to "sqlite" (bug #251408).
(Portage version: 13623-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog6
-rw-r--r--dev-python/django/django-1.0.2-r1.ebuild21
-rw-r--r--dev-python/django/django-9999.ebuild48
3 files changed, 42 insertions, 33 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index fd8b6663d913..81966c90e4d2 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/django
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.32 2009/05/16 05:15:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.33 2009/05/18 14:58:48 arfrever Exp $
+
+ 18 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ django-1.0.2-r1.ebuild:
+ Rename "sqlite3" USE flag to "sqlite" (bug #251408).
16 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
django-1.0.2-r1.ebuild:
diff --git a/dev-python/django/django-1.0.2-r1.ebuild b/dev-python/django/django-1.0.2-r1.ebuild
index ce1423e22dc7..a614ee9aab45 100644
--- a/dev-python/django/django-1.0.2-r1.ebuild
+++ b/dev-python/django/django-1.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.2-r1.ebuild,v 1.3 2009/05/16 05:15:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.2-r1.ebuild,v 1.4 2009/05/18 14:58:48 arfrever Exp $
EAPI="2"
@@ -18,19 +18,19 @@ SRC_URI="http://media.djangoproject.com/releases/${PV}/${MY_P}.tar.gz
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc examples mysql postgres sqlite3 test"
+IUSE="doc examples mysql postgres sqlite test"
RDEPEND="dev-python/imaging
- sqlite3? ( || (
+ sqlite? ( || (
( dev-python/pysqlite:2 <dev-lang/python-2.5 )
>=dev-lang/python-2.5[sqlite] ) )
test? ( || (
( dev-python/pysqlite:2 <dev-lang/python-2.5 )
>=dev-lang/python-2.5[sqlite] ) )
postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )
+ mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
+DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-0.3 )"
-DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -38,10 +38,11 @@ DOCS="docs/* AUTHORS"
src_compile() {
distutils_src_compile
+
if use doc ; then
- pushd docs
- emake html || die "docs failed"
- popd
+ pushd docs > /dev/null
+ emake html || die "Generation of HTML documentation failed"
+ popd > /dev/null
fi
}
@@ -52,8 +53,7 @@ DATABASE_ENGINE='sqlite3'
ROOT_URLCONF='tests/urls.py'
SITE_ID=1
__EOF__
- PYTHONPATH="." ${python} tests/runtests.py --settings=settings -v1 \
- || die "tests failed"
+ PYTHONPATH="." ${python} tests/runtests.py --settings=settings -v1 || die "tests failed"
}
src_install() {
@@ -70,6 +70,7 @@ src_install() {
insinto /usr/share/doc/${PF}
doins -r examples
fi
+
if use doc ; then
mv docs/_build/html/{_,.}sources
dohtml txt -r docs/_build/html/*
diff --git a/dev-python/django/django-9999.ebuild b/dev-python/django/django-9999.ebuild
index 77d34c40c061..0cf480f6c2c9 100644
--- a/dev-python/django/django-9999.ebuild
+++ b/dev-python/django/django-9999.ebuild
@@ -1,33 +1,48 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.2 2008/10/06 18:42:46 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.3 2009/05/18 14:58:48 arfrever Exp $
+
+EAPI="2"
ESVN_REPO_URI="http://code.djangoproject.com/svn/django/trunk/"
-inherit bash-completion distutils eutils versionator subversion
+inherit bash-completion distutils eutils subversion versionator
-DESCRIPTION="high-level python web framework"
+DESCRIPTION="High-level python web framework"
HOMEPAGE="http://www.djangoproject.com/"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+KEYWORDS=""
IUSE="doc examples mysql postgres sqlite test"
RDEPEND="dev-python/imaging
sqlite? ( || (
- ( >=dev-python/pysqlite-2.0.3 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5 ) )
+ ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
+ >=dev-lang/python-2.5[sqlite] ) )
test? ( || (
- ( >=dev-python/pysqlite-2.0.3 <dev-lang/python-2.5 )
- >=dev-lang/python-2.5 ) )
+ ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
+ >=dev-lang/python-2.5[sqlite] ) )
postgres? ( dev-python/psycopg )
mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
+ doc? ( >=dev-python/sphinx-0.3 )"
S="${WORKDIR}"
+DOCS="docs/*.txt AUTHORS"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ pushd docs > /dev/null
+ emake html || die "Generation of HTML documentation failed"
+ popd > /dev/null
+ fi
+}
+
src_test() {
+ einfo "Running tests."
cat >> tests/settings.py << __EOF__
DATABASE_ENGINE='sqlite3'
ROOT_URLCONF='tests/urls.py'
@@ -41,23 +56,12 @@ __EOF__
PYTHONPATH="." ${python} tests/runtests.py --settings=settings -v1 || die "tests failed"
}
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- cd docs
- emake html || die "generating html docs failed"
- fi
-}
-
src_install() {
distutils_python_version
-
- site_pkgs="/usr/$(get_libdir)/python${PYVER}/site-packages/"
+ site_pkgs="$(python_get_sitedir)"
export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
dodir ${site_pkgs}
- DOCS="docs/*.txt AUTHORS"
distutils_src_install
dobin django/bin/{compile-messages,daily_cleanup,make-messages,unique-messages,profiling/gather_profile_stats}.py