summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-12-03 01:34:41 +0000
committerChris Reffett <creffett@gentoo.org>2013-12-03 01:34:41 +0000
commit4df396f6fadcf4c8ba2749ecfe4af0c3790d5f6a (patch)
treef4053f48387ee88ada7aac1cfd66cb8f08dbbc14 /dev-python/django
parentSecurity bump wrt bug 489050 (diff)
downloadgentoo-2-4df396f6fadcf4c8ba2749ecfe4af0c3790d5f6a.tar.gz
gentoo-2-4df396f6fadcf4c8ba2749ecfe4af0c3790d5f6a.tar.bz2
gentoo-2-4df396f6fadcf4c8ba2749ecfe4af0c3790d5f6a.zip
Cleanup wrt bug 489214
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog6
-rw-r--r--dev-python/django/django-1.4.5.ebuild97
-rw-r--r--dev-python/django/django-1.5.1.ebuild82
3 files changed, 5 insertions, 180 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index ab8ba53e33ad..357b361ac7c8 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/django
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.119 2013/10/22 11:43:30 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.120 2013/12/03 01:34:41 creffett Exp $
+
+ 03 Dec 2013; Chris Reffett <creffett@gentoo.org> -django-1.4.5.ebuild,
+ -django-1.5.1.ebuild:
+ Cleanup wrt bug 489214
22 Oct 2013; Fabian Groffen <grobian@gentoo.org> django-1.5.4.ebuild:
Marked ~x64-macos, bug #487670
diff --git a/dev-python/django/django-1.4.5.ebuild b/dev-python/django/django-1.4.5.ebuild
deleted file mode 100644
index ef0d17ac2d03..000000000000
--- a/dev-python/django/django-1.4.5.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.4.5.ebuild,v 1.5 2013/09/05 18:46:06 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-PYTHON_REQ_USE='sqlite?'
-
-inherit bash-completion-r1 distutils-r1 versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- mysql? ( >=dev-python/mysql-python-1.2.3[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
- test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-python_prepare_all() {
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py || die
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. \
- "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-src_test() {
- # Port conflict in django.test.testcases.LiveServerTestCase.
- # Several other races with temp files.
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
-
-src_install() {
- distutils-r1_src_install
- webapp_src_install
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newbashcomp extras/django_bash_completion ${PN}
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/.
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/.
-}
-
-pkg_postinst() {
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- elog
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
-
- # XXX: call webapp_pkg_postinst? the old ebuild didn't do that...
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.5.1.ebuild b/dev-python/django/django-1.5.1.ebuild
deleted file mode 100644
index 485609e048d2..000000000000
--- a/dev-python/django/django-1.5.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.5.1.ebuild,v 1.4 2013/06/02 04:22:26 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE='sqlite?'
-WEBAPP_NO_AUTO_INSTALL="yes"
-
-inherit bash-completion-r1 distutils-r1 versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- mysql? ( >=dev-python/mysql-python-1.2.3[${PY2_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
- test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.5-objects.patch \
- "${FILESDIR}"/${PN}-1.5-py3tests.patch )
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- fi
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- # https://code.djangoproject.com/ticket/20514
- PYTHONPATH=. \
- "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-src_test() {
- # Port conflict in django.test.testcases.LiveServerTestCase.
- # Several other races with temp files.
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
-
-src_install() {
- distutils-r1_src_install
- webapp_src_install
-}
-
-python_install_all() {
- newbashcomp extras/django_bash_completion ${PN}
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- local HTML_DOCS=( docs/_build/html/. )
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/.
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "A copy of the admin media is available to webapp-config for installation in a"
- elog "webroot, as well as the traditional location in python's site-packages dir"
- elog "for easy development."
- webapp_pkg_postinst
-}