summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-07-31 12:36:06 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-07-31 12:36:06 +0000
commit42013768e4fa02b7e693e7e38e4173eed26d886e (patch)
tree119c85af11810affc604fd67d119b7420a475cee /dev-python/django
parentFix bug #428696 (diff)
downloadgentoo-2-42013768e4fa02b7e693e7e38e4173eed26d886e.tar.gz
gentoo-2-42013768e4fa02b7e693e7e38e4173eed26d886e.tar.bz2
gentoo-2-42013768e4fa02b7e693e7e38e4173eed26d886e.zip
Remove old
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog7
-rw-r--r--dev-python/django/django-1.1.4.ebuild89
-rw-r--r--dev-python/django/django-1.2.5.ebuild95
-rw-r--r--dev-python/django/django-1.3.1-r1.ebuild111
-rw-r--r--dev-python/django/django-1.3.ebuild95
-rw-r--r--dev-python/django/django-1.4.ebuild109
6 files changed, 6 insertions, 500 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 3d5c2b0a48c0..dd7a3999b9fe 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.81 2012/07/31 12:01:53 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.82 2012/07/31 12:36:06 ago Exp $
+
+ 31 Jul 2012; Agostino Sarubbo <ago@gentoo.org> -django-1.1.4.ebuild,
+ -django-1.2.5.ebuild, -django-1.3.1-r1.ebuild, -django-1.3.ebuild,
+ -django-1.4.ebuild:
+ Remove old
*django-1.4.1 (31 Jul 2012)
*django-1.3.2 (31 Jul 2012)
diff --git a/dev-python/django/django-1.1.4.ebuild b/dev-python/django/django-1.1.4.ebuild
deleted file mode 100644
index 56899af49281..000000000000
--- a/dev-python/django/django-1.1.4.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.1.4.ebuild,v 1.3 2012/05/28 19:38:23 xarthisius Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="examples mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_test() {
- testing() {
- cat >> tests/settings.py << __EOF__
-DATABASE_ENGINE='sqlite3'
-DATABASE_NAME='test.db'
-ROOT_URLCONF='tests/urls.py'
-SITE_ID=1
-__EOF__
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=settings -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.2.5.ebuild b/dev-python/django/django-1.2.5.ebuild
deleted file mode 100644
index 7f96b575c01c..000000000000
--- a/dev-python/django/django-1.2.5.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.2.5.ebuild,v 1.5 2012/05/28 19:38:23 xarthisius Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.3.1-r1.ebuild b/dev-python/django/django-1.3.1-r1.ebuild
deleted file mode 100644
index 78db8fcb5778..000000000000
--- a/dev-python/django/django-1.3.1-r1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.3.1-r1.ebuild,v 1.3 2011/12/21 07:06:46 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion-r1 distutils eutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/README AUTHORS"
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-djangodocs_extension.patch"
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp extras/django_bash_completion ${PN} || die
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.3.ebuild b/dev-python/django/django-1.3.ebuild
deleted file mode 100644
index 20bd1021b8c1..000000000000
--- a/dev-python/django/django-1.3.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.3.ebuild,v 1.4 2012/05/28 19:38:23 xarthisius Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.4.ebuild b/dev-python/django/django-1.4.ebuild
deleted file mode 100644
index 906bfa269c46..000000000000
--- a/dev-python/django/django-1.4.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.4.ebuild,v 1.3 2012/05/28 19:38:23 xarthisius Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion-r1 distutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg:2 )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp extras/django_bash_completion ${PN} || die
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}