summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-09-15 12:31:59 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-09-15 12:31:59 +0000
commit097447cc5e57a59c5ef8baebf8b3807c85f1c622 (patch)
treed813c8d9cf8ca34a1b0730e48bdcea744e586f1a /dev-python/django
parentuse ${P} in SRC_URI (diff)
downloadgentoo-2-097447cc5e57a59c5ef8baebf8b3807c85f1c622.tar.gz
gentoo-2-097447cc5e57a59c5ef8baebf8b3807c85f1c622.tar.bz2
gentoo-2-097447cc5e57a59c5ef8baebf8b3807c85f1c622.zip
Version bump django to 1.5.4.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog8
-rw-r--r--dev-python/django/django-1.5.4.ebuild82
-rw-r--r--dev-python/django/files/django-1.5.4-objects.patch31
3 files changed, 120 insertions, 1 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 0bf943f7203d..2ebccbcae18b 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.114 2013/09/15 10:56:08 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.115 2013/09/15 12:31:58 djc Exp $
+
+*django-1.5.4 (15 Sep 2013)
+
+ 15 Sep 2013; Dirkjan Ochtman <djc@gentoo.org> +django-1.5.4.ebuild,
+ +files/django-1.5.4-objects.patch:
+ Version bump django to 1.5.4.
15 Sep 2013; Dirkjan Ochtman <djc@gentoo.org> -django-1.3.2.ebuild,
-django-1.3.4.ebuild, -django-1.4.1.ebuild, -django-1.4.2-r2.ebuild,
diff --git a/dev-python/django/django-1.5.4.ebuild b/dev-python/django/django-1.5.4.ebuild
new file mode 100644
index 000000000000..1fc8102159ce
--- /dev/null
+++ b/dev-python/django/django-1.5.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.5.4.ebuild,v 1.1 2013/09/15 12:31:58 djc Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE='sqlite?'
+WEBAPP_NO_AUTO_INSTALL="yes"
+
+inherit bash-completion-r1 distutils-r1 versionator webapp
+
+MY_P="Django-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
+SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc mysql postgres sqlite test"
+
+PY2_USEDEP=$(python_gen_usedep 'python2*')
+RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/mysql-python-1.2.3[${PY2_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
+ test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.4-objects.patch \
+ "${FILESDIR}"/${PN}-1.5-py3tests.patch )
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ # https://code.djangoproject.com/ticket/20514
+ PYTHONPATH=. \
+ "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ # Port conflict in django.test.testcases.LiveServerTestCase.
+ # Several other races with temp files.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+src_install() {
+ distutils-r1_src_install
+ webapp_src_install
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}
+
+ if use doc; then
+ rm -fr docs/_build/html/_sources
+ local HTML_DOCS=( docs/_build/html/. )
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r django/contrib/admin/static/admin/.
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "A copy of the admin media is available to webapp-config for installation in a"
+ elog "webroot, as well as the traditional location in python's site-packages dir"
+ elog "for easy development."
+ webapp_pkg_postinst
+}
diff --git a/dev-python/django/files/django-1.5.4-objects.patch b/dev-python/django/files/django-1.5.4-objects.patch
new file mode 100644
index 000000000000..48e649081d34
--- /dev/null
+++ b/dev-python/django/files/django-1.5.4-objects.patch
@@ -0,0 +1,31 @@
+Remove un-needed objects.inv files from d'loading during doc build
+diff -ur Django-1.5.1.orig/docs/conf.py Django-1.5.1/docs/conf.py
+--- docs/conf.py 2013-03-29 04:10:14.000000000 +0800
++++ docs/conf.py 2013-05-28 01:54:49.695008477 +0800
+@@ -91,12 +91,6 @@
+
+ # Links to Python's docs should reference the most recent version of the 2.x
+ # branch, which is located at this URL.
+-intersphinx_mapping = {
+- 'python': ('http://docs.python.org/2.7', None),
+- 'sphinx': ('http://sphinx.pocoo.org/', None),
+- 'six': ('http://pythonhosted.org/six/', None),
+- 'simplejson': ('http://simplejson.readthedocs.org/en/latest/', None),
+-}
+
+ # Python's docs don't change every week.
+ intersphinx_cache_limit = 90 # days
+# Fix creation of html docs on python 3
+# https://github.com/django/django/commit/a5733fcd7be7adb8b236825beff4ccda19900f9e
+diff -ur Django-1.5.1.orig/docs/_ext/djangodocs.py Django-1.5.1/docs/_ext/djangodocs.py
+--- docs/_ext/djangodocs.py 2013-03-29 04:07:21.000000000 +0800
++++ docs/_ext/djangodocs.py 2013-05-28 02:34:59.057009144 +0800
+@@ -204,7 +204,7 @@
+ if t == "templatefilter" and l == "ref/templates/builtins"],
+ }
+ outfilename = os.path.join(self.outdir, "templatebuiltins.js")
+- with open(outfilename, 'wb') as fp:
++ with open(outfilename, 'w') as fp:
+ fp.write('var django_template_builtins = ')
+ json.dump(templatebuiltins, fp)
+ fp.write(';\n')