summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-06 09:32:46 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-06 09:32:46 +0000
commitc7546c3454a538d04bf84c46fe321524ddf3c668 (patch)
tree76239eb9ff464226d1ee1972c93d1d974dc6f19a /dev-python/django-tastypie
parentMask dev-util/lafilefixer, wrt bug #289899 (diff)
downloadgentoo-2-c7546c3454a538d04bf84c46fe321524ddf3c668.tar.gz
gentoo-2-c7546c3454a538d04bf84c46fe321524ddf3c668.tar.bz2
gentoo-2-c7546c3454a538d04bf84c46fe321524ddf3c668.zip
tidyup
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-tastypie')
-rw-r--r--dev-python/django-tastypie/ChangeLog6
-rw-r--r--dev-python/django-tastypie/django-tastypie-0.9.15.ebuild10
-rw-r--r--dev-python/django-tastypie/files/runtests.patch4
3 files changed, 10 insertions, 10 deletions
diff --git a/dev-python/django-tastypie/ChangeLog b/dev-python/django-tastypie/ChangeLog
index 36aa9053bc3b..70fe6a1785a7 100644
--- a/dev-python/django-tastypie/ChangeLog
+++ b/dev-python/django-tastypie/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/django-tastypie
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-tastypie/ChangeLog,v 1.6 2013/06/03 07:17:51 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-tastypie/ChangeLog,v 1.7 2013/06/06 09:32:46 idella4 Exp $
+
+ 06 Jun 2013; Ian Delaney <idella4@gentoo.org> django-tastypie-0.9.15.ebuild,
+ files/runtests.patch:
+ tidyup
3 June 2013; Ian Delaney <idella4@gentoo.org> +runtests.patch,
django-tastypie-0.9.15.ebuild:
diff --git a/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild b/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild
index 97f000ce794e..d97fe3a50f7c 100644
--- a/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild
+++ b/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild,v 1.3 2013/06/03 07:08:29 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-tastypie/django-tastypie-0.9.15.ebuild,v 1.4 2013/06/06 09:32:46 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -42,11 +42,7 @@ DEPEND="${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
)"
-python_prepare_all() {
- # skip run tests script
- use test && epatch "${FILESDIR}"/runtests.patch
- distutils-r1_python_prepare_all
-}
+PATCHES=( "${FILESDIR}"/runtests.patch )
python_compile_all() {
use doc && emake -C docs html
@@ -57,7 +53,7 @@ src_test() {
}
python_test() {
- PYTHONPATH=.:tests ./tests/run_all_tests.sh
+ PYTHONPATH=.:tests ./tests/run_all_tests.sh || die
}
python_install_all() {
diff --git a/dev-python/django-tastypie/files/runtests.patch b/dev-python/django-tastypie/files/runtests.patch
index 384bdef07b38..473d3338101a 100644
--- a/dev-python/django-tastypie/files/runtests.patch
+++ b/dev-python/django-tastypie/files/runtests.patch
@@ -28,7 +28,7 @@ diff -ur django-tastypie-0.9.15.oirg/tests/run_all_tests.sh django-tastypie-0.9.
+ continue
+ else
+ echo "Test ${type} failed"
-+ exit -1
++ exit 1
+ fi
elif [ $type == 'gis' ]; then
- createdb -T template_postgis tastypie.db
@@ -39,7 +39,7 @@ diff -ur django-tastypie-0.9.15.oirg/tests/run_all_tests.sh django-tastypie-0.9.
- echo; echo
+ if ! django-admin.py test $type --settings=settings_$type; then
+ echo "Test ${type} failed"
-+ exit -1
++ exit 1
+ else
+ echo; echo
+ fi