summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-26 03:08:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-26 03:08:02 +0000
commit5a21657cedc105296e2241935e44a75d2d9ebfc9 (patch)
tree42ef665afedf10a25062fab303b7482ffe0c14f1 /dev-python/django-oauth-plus
parentBump (diff)
downloadgentoo-2-5a21657cedc105296e2241935e44a75d2d9ebfc9.tar.gz
gentoo-2-5a21657cedc105296e2241935e44a75d2d9ebfc9.tar.bz2
gentoo-2-5a21657cedc105296e2241935e44a75d2d9ebfc9.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/django-oauth-plus')
-rw-r--r--dev-python/django-oauth-plus/ChangeLog8
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.1.4.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/django-oauth-plus/ChangeLog b/dev-python/django-oauth-plus/ChangeLog
index aa9e6956fb4d..8710908f8e9d 100644
--- a/dev-python/django-oauth-plus/ChangeLog
+++ b/dev-python/django-oauth-plus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-oauth-plus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/ChangeLog,v 1.5 2013/07/08 06:49:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/ChangeLog,v 1.6 2013/08/26 03:08:02 patrick Exp $
+
+*django-oauth-plus-2.1.4 (26 Aug 2013)
+
+ 26 Aug 2013; Patrick Lauer <patrick@gentoo.org>
+ +django-oauth-plus-2.1.4.ebuild:
+ Bump
*django-oauth-plus-2.1.2 (08 Jul 2013)
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.1.4.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.1.4.ebuild
new file mode 100644
index 000000000000..7775827c1eb7
--- /dev/null
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/django-oauth-plus-2.1.4.ebuild,v 1.1 2013/08/26 03:08:02 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
+HOMEPAGE="http://pypi.python.org/pypi/django-oauth-plus http://code.welldev.org/django-oauth-plus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/django-1.2.4[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_hg[${PYTHON_USEDEP}]
+ test? ( dev-python/south[${PYTHON_USEDEP}] )"
+
+python_test() {
+ if "${PYTHON}" oauth_provider/runtests/manage.py test; then
+ einfo "Testsuite passed under ${EPYTHON}"
+ else
+ die "Testsuite failed under ${EPYTHON}"
+ fi
+}