summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2012-04-25 12:37:22 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2012-04-25 12:37:22 +0000
commit6ddc7df690151410596b872f1f806b69386c1925 (patch)
tree3134baad3427b3724d3d3389007fc669ba1c46b3 /dev-python/django-compressor
parentInitial commit, ebuild by idella4 (diff)
downloadgentoo-2-6ddc7df690151410596b872f1f806b69386c1925.tar.gz
gentoo-2-6ddc7df690151410596b872f1f806b69386c1925.tar.bz2
gentoo-2-6ddc7df690151410596b872f1f806b69386c1925.zip
Initial commit, ebuild by idella4
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/django-compressor')
-rw-r--r--dev-python/django-compressor/ChangeLog10
-rw-r--r--dev-python/django-compressor/Manifest3
-rw-r--r--dev-python/django-compressor/django-compressor-1.1.2.ebuild53
-rw-r--r--dev-python/django-compressor/metadata.xml14
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/django-compressor/ChangeLog b/dev-python/django-compressor/ChangeLog
new file mode 100644
index 000000000000..bb6598c5ddeb
--- /dev/null
+++ b/dev-python/django-compressor/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/django-compressor
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-compressor/ChangeLog,v 1.1 2012/04/25 12:37:22 tampakrap Exp $
+
+*django-compressor-1.1.2 (25 Apr 2012)
+
+ 25 Apr 2012; Theo Chatzimichos <tampakrap@gentoo.org>
+ +django-compressor-1.1.2.ebuild, +metadata.xml:
+ Initial commit, ebuild by idella4
+
diff --git a/dev-python/django-compressor/Manifest b/dev-python/django-compressor/Manifest
new file mode 100644
index 000000000000..465b0bc8eb68
--- /dev/null
+++ b/dev-python/django-compressor/Manifest
@@ -0,0 +1,3 @@
+DIST django-compressor-1.1.2.tar.gz 59735 RMD160 3d39fefe5241cac6a2130ae2afb17fc873191064 SHA1 e62f9275effe837e7ecf0602234196b508e89bbf SHA256 d164a428248fd62af402920bead041fd9622e76bcade80ff6e782788e8aca0bc
+EBUILD django-compressor-1.1.2.ebuild 1277 RMD160 1e6b2307c0e0469ebaf52df331b06245e8114b9a SHA1 e71cf41dc25c2d8dba7a175e5d20425e06631dcb SHA256 caec305d7c7024b9936164d4961efefb462d232073377e12a654afc36e74da82
+MISC metadata.xml 354 RMD160 091888911fc3977462b1015a07a860a68ab6ee9e SHA1 dfd9a92e0cdac92fbeccaae8038db941a4273b09 SHA256 286b386bcfeeacbeace854ed0f9904d845b8397b957963d95bae64534a6decb2
diff --git a/dev-python/django-compressor/django-compressor-1.1.2.ebuild b/dev-python/django-compressor/django-compressor-1.1.2.ebuild
new file mode 100644
index 000000000000..3a83763d01a4
--- /dev/null
+++ b/dev-python/django-compressor/django-compressor-1.1.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-compressor/django-compressor-1.1.2.ebuild,v 1.1 2012/04/25 12:37:22 tampakrap Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+inherit distutils
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Allows to define regrouped/postcompiled content 'on the fly' inside of django template"
+HOMEPAGE="http://pypi.python.org/pypi/django_compressor/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+LICENSE="MIT"
+SLOT="0"
+
+PYTHON_MODNAME="compressor"
+
+# tests I think worked in the live ebuild fine. It's tripping over a
+# setting missing; COMPRESS_ROOT in compressor/conf.py
+RESTRICT="test"
+S=${WORKDIR}/${MY_PN}-${PV}
+
+RDEPEND=""
+DEPEND="${RDEPEND} >=dev-python/django-1.1.4
+ dev-python/setuptools
+ dev-python/django-appconf
+ dev-python/versiontools
+ test? ( dev-python/twill )"
+
+src_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+ testing() {
+ local test
+ for test in tests/tests/*.py
+ do
+ PYTHONPATH=. "$(PYTHON)" "${test}" || die "${test} failed with Python ${PYTHON_ABI}"
+ einfo "Test "${test}" completed OK"
+ done
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r compressor/
+ fi
+}
diff --git a/dev-python/django-compressor/metadata.xml b/dev-python/django-compressor/metadata.xml
new file mode 100644
index 000000000000..472ba4684030
--- /dev/null
+++ b/dev-python/django-compressor/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johneed@hotmail.com</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <maintainer>
+ <email>tampakrap@gentoo.org</email>
+ <name>Theo Chatzimichos</name>
+ </maintainer>
+ <herd>python</herd>
+</pkgmetadata>
+