summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-09 11:01:57 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-09 11:01:57 +0000
commit29f152034cc2c95136d7444b0ce0eb604a856307 (patch)
treee5ec13b2c1c4acf92d34d1a6d683131c82c4e036 /dev-python/django-celery
parentAdd DEPEND on sys-devel/gettext by Nikoli <nikoli@gmx.us>, bug #507222. (diff)
downloadgentoo-2-29f152034cc2c95136d7444b0ce0eb604a856307.tar.gz
gentoo-2-29f152034cc2c95136d7444b0ce0eb604a856307.tar.bz2
gentoo-2-29f152034cc2c95136d7444b0ce0eb604a856307.zip
bump; add py3 support, update deps, test phase, initially masked until unmasking of celery-3.1.10
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-celery')
-rw-r--r--dev-python/django-celery/ChangeLog8
-rw-r--r--dev-python/django-celery/django-celery-3.1.9.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/django-celery/ChangeLog b/dev-python/django-celery/ChangeLog
index 39edd5c08b45..975316a20511 100644
--- a/dev-python/django-celery/ChangeLog
+++ b/dev-python/django-celery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-celery
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/ChangeLog,v 1.15 2014/03/30 09:17:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/ChangeLog,v 1.16 2014/04/09 11:01:57 idella4 Exp $
+
+*django-celery-3.1.9 (09 Apr 2014)
+
+ 09 Apr 2014; Ian Delaney <idella4@gentoo.org> +django-celery-3.1.9.ebuild:
+ bump; add py3 support, update deps, test phase, initially masked until
+ unmasking of celery-3.1.10
30 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer as talked with him (#398377)
diff --git a/dev-python/django-celery/django-celery-3.1.9.ebuild b/dev-python/django-celery/django-celery-3.1.9.ebuild
new file mode 100644
index 000000000000..3409e9da2213
--- /dev/null
+++ b/dev-python/django-celery/django-celery-3.1.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/django-celery-3.1.9.ebuild,v 1.1 2014/04/09 11:01:57 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Celery Integration for Django"
+HOMEPAGE="http://celeryproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+PY2_USEDEP=$(python_gen_usedep python2_7)
+RDEPEND=">=dev-python/celery-3.0.19[${PYTHON_USEDEP}]
+ >=dev-python/django-1.3[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ dev-python/django-nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-memcached[${PY2_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-issuetracker[${PY2_USEDEP}]
+ dev-python/python-memcached[${PY2_USEDEP}]
+ )"
+
+PY27_REQUSE="$(python_gen_useflags 'python2.7')"
+REQUIRED_USE="
+ doc? ( ${PY27_REQUSE} )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # py3 has masses of errors
+ # https://github.com/celery/django-celery/issues/321
+ if ! python_is_python3; then
+ sed -e s':test_forget:_&:' -i djcelery/tests/test_backends/test_database.py || die
+ "${PYTHON}" tests/manage.py test
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}