summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-29 20:36:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-29 20:36:14 +0000
commit9e71c34b8a6482e9f3b2ba208df97afa5831ced7 (patch)
treed2d3d13b313a19498af3917713ac156b212f4411 /dev-python/decorator
parentVersion bump. Set SUPPORT_PYTHON_ABIS. Add missing run-time dependency on dev... (diff)
downloadgentoo-2-9e71c34b8a6482e9f3b2ba208df97afa5831ced7.tar.gz
gentoo-2-9e71c34b8a6482e9f3b2ba208df97afa5831ced7.tar.bz2
gentoo-2-9e71c34b8a6482e9f3b2ba208df97afa5831ced7.zip
Version bump.
(Portage version: 14170-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/decorator')
-rw-r--r--dev-python/decorator/ChangeLog8
-rw-r--r--dev-python/decorator/decorator-2.2.0.ebuild25
-rw-r--r--dev-python/decorator/decorator-2.3.2.ebuild21
-rw-r--r--dev-python/decorator/decorator-3.1.2.ebuild49
4 files changed, 56 insertions, 47 deletions
diff --git a/dev-python/decorator/ChangeLog b/dev-python/decorator/ChangeLog
index c10b9932877e..4f42deba8138 100644
--- a/dev-python/decorator/ChangeLog
+++ b/dev-python/decorator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/decorator
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.6 2009/08/04 23:50:40 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.7 2009/08/29 20:36:14 arfrever Exp $
+
+*decorator-3.1.2 (29 Aug 2009)
+
+ 29 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -decorator-2.2.0.ebuild, -decorator-2.3.2.ebuild, +decorator-3.1.2.ebuild:
+ Version bump.
04 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
decorator-3.0.1.ebuild:
diff --git a/dev-python/decorator/decorator-2.2.0.ebuild b/dev-python/decorator/decorator-2.2.0.ebuild
deleted file mode 100644
index a69bdeb31d8d..000000000000
--- a/dev-python/decorator/decorator-2.2.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-2.2.0.ebuild,v 1.3 2008/05/25 12:40:20 coldwind Exp $
-
-inherit distutils
-
-DESCRIPTION="Simplifies the usage of decorators for the average programmer"
-HOMEPAGE="http://www.phyast.pitt.edu/~micheles/python/documentation.html"
-SRC_URI="http://www.phyast.pitt.edu/~micheles/python/${P}.zip"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="doc"
-S="${WORKDIR}"
-DEPEND="app-arch/unzip"
-DOCS="CHANGES.txt documentation.txt documentation.pdf"
-
-src_install() {
- distutils_src_install
- use doc && dohtml documentation.html
-}
-
-src_test() {
- PYTHONPATH=. "${python}" doctester.py documentation.txt || die "tests failed"
-}
diff --git a/dev-python/decorator/decorator-2.3.2.ebuild b/dev-python/decorator/decorator-2.3.2.ebuild
deleted file mode 100644
index 3d7ce9af8dd9..000000000000
--- a/dev-python/decorator/decorator-2.3.2.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-2.3.2.ebuild,v 1.2 2009/05/22 21:00:21 patrick Exp $
-
-inherit distutils
-
-DESCRIPTION="Simplifies the usage of decorators for the average programmer"
-HOMEPAGE="http://www.phyast.pitt.edu/~micheles/python/documentation.html"
-SRC_URI="http://pypi.python.org/packages/source/d/decorator/${P}.tar.gz"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="doc"
-DEPEND="app-arch/unzip"
-RDEPEND=""
-DOCS="CHANGES.txt documentation.txt"
-
-src_install() {
- distutils_src_install
- use doc && dohtml documentation.html
-}
diff --git a/dev-python/decorator/decorator-3.1.2.ebuild b/dev-python/decorator/decorator-3.1.2.ebuild
new file mode 100644
index 000000000000..0ec0e7700d56
--- /dev/null
+++ b/dev-python/decorator/decorator-3.1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.1.2.ebuild,v 1.1 2009/08/29 20:36:14 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="http://pypi.python.org/pypi/decorator"
+SRC_URI="http://pypi.python.org/packages/source/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
+DOCS="CHANGES.txt README.txt"
+
+src_test() {
+ # multiprocessing module is available only in Python >=2.6, and isn't used anyway.
+ sed -i -e '/multiprocessing/d' documentation.py || die
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" documentation.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dodoc documentation.pdf || die "dodoc pdf doc failed"
+ dohtml documentation.html || die "dohtml html doc failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize decorator.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}