summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-04 23:50:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-04 23:50:40 +0000
commit8572b201d2846d73ab304083aef2ac823a978275 (patch)
tree1998e55d345f7f9e62cf8cd6af161f64bf44a870 /dev-python/decorator
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-8572b201d2846d73ab304083aef2ac823a978275.tar.gz
gentoo-2-8572b201d2846d73ab304083aef2ac823a978275.tar.bz2
gentoo-2-8572b201d2846d73ab304083aef2ac823a978275.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 13912-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/decorator')
-rw-r--r--dev-python/decorator/ChangeLog6
-rw-r--r--dev-python/decorator/decorator-3.0.1.ebuild27
2 files changed, 28 insertions, 5 deletions
diff --git a/dev-python/decorator/ChangeLog b/dev-python/decorator/ChangeLog
index c030097c2239..c10b9932877e 100644
--- a/dev-python/decorator/ChangeLog
+++ b/dev-python/decorator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/decorator
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.5 2009/05/22 21:00:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.6 2009/08/04 23:50:40 arfrever Exp $
+
+ 04 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ decorator-3.0.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
22 May 2009; Patrick Lauer <patrick@gentoo.org> decorator-2.3.2.ebuild:
SRC_URI fix for 2.3.2, fixes #269086
diff --git a/dev-python/decorator/decorator-3.0.1.ebuild b/dev-python/decorator/decorator-3.0.1.ebuild
index 139b0700571d..6d1f5c569be2 100644
--- a/dev-python/decorator/decorator-3.0.1.ebuild
+++ b/dev-python/decorator/decorator-3.0.1.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.0.1.ebuild,v 1.1 2009/03/27 11:41:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.0.1.ebuild,v 1.2 2009/08/04 23:50:40 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -13,18 +16,34 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
+DEPEND=""
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
DOCS="CHANGES.txt README.txt"
src_test() {
- # multiprocessing only in python-2.6 and above, and not use anyway
+ # multiprocessing module is available only in Python >=2.6, and isn't used anyway.
sed -i -e '/multiprocessing/d' documentation.py || die
- PYTHONPATH=build/lib "${python}" documentation.py || die "tests failed"
+ testing() {
+ PYTHONPATH="build/lib-${PYTHON_ABI}" "$(get_python)" documentation.py
+ }
+ python_execute_function testing
}
src_install() {
distutils_src_install
- if use doc;then
+ if use doc; then
dodoc documentation.pdf || die "dodoc pdf doc failed"
dohtml documentation.html || die "dohtml html doc failed"
fi
}
+
+pkg_postinst() {
+ python_mod_optimize decorator.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}