summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-01-25 03:17:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-01-25 03:17:36 +0000
commit72f3611b1415bb3d669510d48741c16321a2aa4a (patch)
treef5125e8864e83fb2049b821e2f6992ca65f519a8 /dev-python/dbus-python
parentVersion Bump. Closes bug #163387. (diff)
downloadgentoo-2-72f3611b1415bb3d669510d48741c16321a2aa4a.tar.gz
gentoo-2-72f3611b1415bb3d669510d48741c16321a2aa4a.tar.bz2
gentoo-2-72f3611b1415bb3d669510d48741c16321a2aa4a.zip
Completely re-written Python bindings by Simon McVittie <simon.mcvittie@collabora.co.uk>. They've become the official bindings.
(Portage version: 2.1.2-r3)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog9
-rw-r--r--dev-python/dbus-python/dbus-python-0.80.1.ebuild39
-rw-r--r--dev-python/dbus-python/files/digest-dbus-python-0.80.13
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 13b9c42e17ff..e5149a951797 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/dbus-python
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.10 2007/01/23 05:01:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.11 2007/01/25 03:17:36 cardoe Exp $
+
+*dbus-python-0.80.1 (25 Jan 2007)
+
+ 25 Jan 2007; Doug Goldstein <cardoe@gentoo.org>
+ +dbus-python-0.80.1.ebuild:
+ Completely re-written Python bindings by Simon McVittie
+ <simon.mcvittie@collabora.co.uk>. They've become the official bindings.
23 Jan 2007; Jeroen Roovers <jer@gentoo.org> dbus-python-0.71.ebuild:
Stable for HPPA (bug #162880).
diff --git a/dev-python/dbus-python/dbus-python-0.80.1.ebuild b/dev-python/dbus-python/dbus-python-0.80.1.ebuild
new file mode 100644
index 000000000000..2b56291efb86
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-0.80.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.80.1.ebuild,v 1.1 2007/01/25 03:17:36 cardoe Exp $
+
+inherit distutils
+
+DESCRIPTION="Python bindings for the D-Bus messagebus."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
+http://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-python/pyrex-0.9.3-r2
+ >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-0.91"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}"/usr/lib/python*/site-packages/dbus
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"/usr/lib/python*/site-packages/dbus
+}
diff --git a/dev-python/dbus-python/files/digest-dbus-python-0.80.1 b/dev-python/dbus-python/files/digest-dbus-python-0.80.1
new file mode 100644
index 000000000000..3015b40d8794
--- /dev/null
+++ b/dev-python/dbus-python/files/digest-dbus-python-0.80.1
@@ -0,0 +1,3 @@
+MD5 42dced5c87a47589ea0b6535ae2e4918 dbus-python-0.80.1.tar.gz 443783
+RMD160 164ad75a0140eec1c7132a9701d699621a067557 dbus-python-0.80.1.tar.gz 443783
+SHA256 2b9beef33d21e54c524869d5ae23557a92ab1b97eebe3c9da5f87bc75fc66e18 dbus-python-0.80.1.tar.gz 443783