summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-16 02:19:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-16 02:19:47 +0000
commitb0f173982a7d09e6e9c7aba63b867bc0640f2e61 (patch)
tree41b1123614f3b649b01a05389986e0f90ad91441 /dev-python/cython
parentVersion bump, remove old. (diff)
downloadgentoo-2-b0f173982a7d09e6e9c7aba63b867bc0640f2e61.tar.gz
gentoo-2-b0f173982a7d09e6e9c7aba63b867bc0640f2e61.tar.bz2
gentoo-2-b0f173982a7d09e6e9c7aba63b867bc0640f2e61.zip
Bump for #442946
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/ChangeLog8
-rw-r--r--dev-python/cython/cython-0.17.1.ebuild53
2 files changed, 59 insertions, 2 deletions
diff --git a/dev-python/cython/ChangeLog b/dev-python/cython/ChangeLog
index 3ac055a597c2..0ff8403bd6f9 100644
--- a/dev-python/cython/ChangeLog
+++ b/dev-python/cython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cython
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.84 2012/06/28 15:48:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.85 2012/11/16 02:19:47 patrick Exp $
+
+*cython-0.17.1 (16 Nov 2012)
+
+ 16 Nov 2012; Patrick Lauer <patrick@gentoo.org> +cython-0.17.1.ebuild:
+ Bump for #442946
28 Jun 2012; Jeroen Roovers <jer@gentoo.org> cython-0.16.ebuild:
Stable for HPPA (bug #418291).
@@ -333,4 +338,3 @@
06 Oct 2007; Ali Polatel <hawking@gentoo.org> +metadata.xml,
+cython-0.9.6.6.ebuild:
Initial import. Ebuild submitted by Samuele Kaplun <kaplun@alice.it>
-
diff --git a/dev-python/cython/cython-0.17.1.ebuild b/dev-python/cython/cython-0.17.1.ebuild
new file mode 100644
index 000000000000..db57992a4b22
--- /dev/null
+++ b/dev-python/cython/cython-0.17.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.17.1.ebuild,v 1.1 2012/11/16 02:19:47 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+
+inherit distutils
+
+MY_PN="Cython"
+MY_P="${MY_PN}-${PV/_/}"
+
+DESCRIPTION="Compiler for writing C extensions for the Python language"
+HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
+SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc examples numpy"
+
+DEPEND="numpy? ( >=dev-python/numpy-1.6.1-r1 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV%_*}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="README.txt ToDo.txt USAGE.txt"
+PYTHON_MODNAME="Cython cython.py pyximport"
+
+src_test() {
+ testing() {
+ "$(PYTHON)" runtests.py -vv --work-dir tests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/cython"
+
+ if use doc; then
+ # "-A c" is for ignoring of "Doc/primes.c".
+ dohtml -A c -r Doc/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Demos/* || die "Installation of examples failed"
+ fi
+}