summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-15 12:11:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-15 12:11:06 +0000
commit7bd582d7e0608cf0cf3b2ecaecec4144400dcd2b (patch)
tree4e12a651e9df83b89388b6907b35781ff919f4d9 /dev-python/cython
parentDelete older ebuild. (diff)
downloadgentoo-2-7bd582d7e0608cf0cf3b2ecaecec4144400dcd2b.tar.gz
gentoo-2-7bd582d7e0608cf0cf3b2ecaecec4144400dcd2b.tar.bz2
gentoo-2-7bd582d7e0608cf0cf3b2ecaecec4144400dcd2b.zip
Version bump.
(Portage version: 2.2.0_alpha8_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/ChangeLog8
-rw-r--r--dev-python/cython/cython-0.14.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/cython/ChangeLog b/dev-python/cython/ChangeLog
index 5f107716f95b..ffe00864dda8 100644
--- a/dev-python/cython/ChangeLog
+++ b/dev-python/cython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cython
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.57 2010/12/11 21:50:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.58 2010/12/15 12:11:06 arfrever Exp $
+
+*cython-0.14 (15 Dec 2010)
+
+ 15 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -cython-0.14_rc0.ebuild, +cython-0.14.ebuild:
+ Version bump.
*cython-0.14_rc0 (11 Dec 2010)
diff --git a/dev-python/cython/cython-0.14.ebuild b/dev-python/cython/cython-0.14.ebuild
new file mode 100644
index 000000000000..4b57dbd878c3
--- /dev/null
+++ b/dev-python/cython/cython-0.14.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.14.ebuild,v 1.1 2010/12/15 12:11:06 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+MY_PN="Cython"
+MY_P="${MY_PN}-${PV/_/.}"
+
+DESCRIPTION="The Cython compiler for writing C extensions for the Python language"
+HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
+SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="README.txt ToDo.txt USAGE.txt"
+PYTHON_MODNAME="Cython pyximport"
+
+src_test() {
+ testing() {
+ rm -fr BUILD
+ "$(PYTHON)" runtests.py -vv
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # "-A c" is for ignoring of "Doc/primes.c".
+ dohtml -A c -r Doc/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Demos/* || die "Installation of examples failed"
+ fi
+}