summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-18 14:22:53 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-18 14:22:53 +0000
commitec929e191eb800da64523f5a0f2c0fcf89fa361c (patch)
treef11e6cffcb4156e1e0c71a44f0fbb3667ad6ddc7 /dev-python/ctypesgen
parentAdd upstream information, version bump wrt bug #458048, thanks to Johan Bergs... (diff)
downloadgentoo-2-ec929e191eb800da64523f5a0f2c0fcf89fa361c.tar.gz
gentoo-2-ec929e191eb800da64523f5a0f2c0fcf89fa361c.tar.bz2
gentoo-2-ec929e191eb800da64523f5a0f2c0fcf89fa361c.zip
Migrate to distutils-r1. Fix and enable tests.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/ctypesgen')
-rw-r--r--dev-python/ctypesgen/ChangeLog10
-rw-r--r--dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild38
2 files changed, 45 insertions, 3 deletions
diff --git a/dev-python/ctypesgen/ChangeLog b/dev-python/ctypesgen/ChangeLog
index 107699202d1d..620b7dad5dae 100644
--- a/dev-python/ctypesgen/ChangeLog
+++ b/dev-python/ctypesgen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ctypesgen
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypesgen/ChangeLog,v 1.25 2012/05/12 01:16:16 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypesgen/ChangeLog,v 1.26 2013/02/18 14:22:53 mgorny Exp $
+
+*ctypesgen-0_p72-r1 (18 Feb 2013)
+
+ 18 Feb 2013; Michał Górny <mgorny@gentoo.org> +ctypesgen-0_p72-r1.ebuild:
+ Migrate to distutils-r1. Fix and enable tests.
12 May 2012; Alexis Ballier <aballier@gentoo.org> ctypesgen-0_p72.ebuild:
keyword ~amd64-fbsd
@@ -78,4 +83,3 @@
22 Mar 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+metadata.xml, +ctypesgen-0_p72.ebuild:
New package. Initial ebuild by me.
-
diff --git a/dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild b/dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild
new file mode 100644
index 000000000000..003fa2441301
--- /dev/null
+++ b/dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild,v 1.1 2013/02/18 14:22:53 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper generator for ctypes"
+HOMEPAGE="http://code.google.com/p/ctypesgen/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ # r73 upstream
+ sed -i -e 's:libc:libm.so.6:' test/math_functions.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r -l test "${BUILD_DIR}"/ || die
+
+ cd "${BUILD_DIR}"/test || die
+ local f
+ for f in {math_functions,simple_macros,structures}.py; do
+ "${PYTHON}" "${f}" || die "Test ${f} fails with ${EPYTHON}"
+ done
+}