summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2007-03-15 16:52:40 +0000
committerMarien Zwart <marienz@gentoo.org>2007-03-15 16:52:40 +0000
commit897cbfc8d76e2231d7ef1390f85e8f0525967840 (patch)
treea9b86fc73b26e16b30be41f75bbe08621f9124b4 /dev-python/ctypes
parentRESTRICT test as it's not supported by upstream. (diff)
downloadgentoo-2-897cbfc8d76e2231d7ef1390f85e8f0525967840.tar.gz
gentoo-2-897cbfc8d76e2231d7ef1390f85e8f0525967840.tar.bz2
gentoo-2-897cbfc8d76e2231d7ef1390f85e8f0525967840.zip
Revision bump with a patch for executable stacks on x86 lifted from python upstream, closes bug #167254, thanks to David Li <matrixhax0r@gmail.com> for reporting.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-python/ctypes')
-rw-r--r--dev-python/ctypes/ChangeLog10
-rw-r--r--dev-python/ctypes/ctypes-1.0.1-r1.ebuild39
-rw-r--r--dev-python/ctypes/files/ctypes-1.0.1-execstack.patch12
-rw-r--r--dev-python/ctypes/files/digest-ctypes-1.0.1-r13
4 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/ctypes/ChangeLog b/dev-python/ctypes/ChangeLog
index 2589a4f1bf8a..afa03d3337bd 100644
--- a/dev-python/ctypes/ChangeLog
+++ b/dev-python/ctypes/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/ctypes
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ChangeLog,v 1.15 2007/02/14 22:30:49 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ChangeLog,v 1.16 2007/03/15 16:52:40 marienz Exp $
+
+*ctypes-1.0.1-r1 (15 Mar 2007)
+
+ 15 Mar 2007; Marien Zwart <marienz@gentoo.org>
+ +files/ctypes-1.0.1-execstack.patch, +ctypes-1.0.1-r1.ebuild:
+ Revision bump with a patch for executable stacks on x86 lifted from python
+ upstream, closes bug #167254, thanks to David Li <matrixhax0r@gmail.com> for
+ reporting.
*ctypes-1.0.1 (14 Feb 2007)
diff --git a/dev-python/ctypes/ctypes-1.0.1-r1.ebuild b/dev-python/ctypes/ctypes-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..57446e91375d
--- /dev/null
+++ b/dev-python/ctypes/ctypes-1.0.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ctypes/ctypes-1.0.1-r1.ebuild,v 1.1 2007/03/15 16:52:40 marienz Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils eutils
+
+DESCRIPTION="Python module allowing to create and manipulate C data types."
+HOMEPAGE="http://starship.python.net/crew/theller/ctypes/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-execstack.patch"
+}
+
+src_install() {
+ DOCS="ACKS ANNOUNCE"
+ distutils_src_install
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/manual
+ doins -r docs/manual/*
+ fi
+}
+
+src_test() {
+ PYTHONPATH="$(ls -d build/lib.*)" "${python}" setup.py test || die "tests failed"
+}
diff --git a/dev-python/ctypes/files/ctypes-1.0.1-execstack.patch b/dev-python/ctypes/files/ctypes-1.0.1-execstack.patch
new file mode 100644
index 000000000000..97e1dc46615e
--- /dev/null
+++ b/dev-python/ctypes/files/ctypes-1.0.1-execstack.patch
@@ -0,0 +1,12 @@
+=== modified file 'source/libffi/src/x86/sysv.S'
+--- source/libffi/src/x86/sysv.S 2007-03-15 16:39:56 +0000
++++ source/libffi/src/x86/sysv.S 2007-03-15 16:40:23 +0000
+@@ -376,3 +376,7 @@
+ #endif
+
+ #endif /* ifndef __x86_64__ */
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+
diff --git a/dev-python/ctypes/files/digest-ctypes-1.0.1-r1 b/dev-python/ctypes/files/digest-ctypes-1.0.1-r1
new file mode 100644
index 000000000000..c86709f7d2a0
--- /dev/null
+++ b/dev-python/ctypes/files/digest-ctypes-1.0.1-r1
@@ -0,0 +1,3 @@
+MD5 bdc75102ebc533e1d708296a346cfee4 ctypes-1.0.1.tar.gz 384668
+RMD160 832c8de0c8490d0ead113ea651b3bdc27e494a63 ctypes-1.0.1.tar.gz 384668
+SHA256 ca52bc06634f750e10e989010412af56ce9f18b08a9d6d6ac8d984cddaf0ce90 ctypes-1.0.1.tar.gz 384668