summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-10-10 18:32:11 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-10-10 18:32:11 +0000
commit962e1f2234b5f9db0ef3911c17f0e982ba5106ee (patch)
tree741057937b326bf5eea567f73231eee38de76409 /dev-python/crcmod
parentBlock <quvi-0.4.0 due to file collisions (bug #386645). (diff)
downloadgentoo-2-962e1f2234b5f9db0ef3911c17f0e982ba5106ee.tar.gz
gentoo-2-962e1f2234b5f9db0ef3911c17f0e982ba5106ee.tar.bz2
gentoo-2-962e1f2234b5f9db0ef3911c17f0e982ba5106ee.zip
added python 3.2 abi support, solves bug #378923.
(Portage version: 2.2.0_alpha64/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/crcmod')
-rw-r--r--dev-python/crcmod/ChangeLog9
-rw-r--r--dev-python/crcmod/crcmod-1.7-r1.ebuild26
2 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/crcmod/ChangeLog b/dev-python/crcmod/ChangeLog
index 339e32bd199d..0a9d0cd3d4cc 100644
--- a/dev-python/crcmod/ChangeLog
+++ b/dev-python/crcmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/crcmod
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/crcmod/ChangeLog,v 1.2 2010/10/10 18:21:17 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/crcmod/ChangeLog,v 1.3 2011/10/10 18:32:11 sbriesen Exp $
+
+*crcmod-1.7-r1 (10 Oct 2011)
+
+ 10 Oct 2011; Stefan Briesenick <sbriesen@gentoo.org> +crcmod-1.7-r1.ebuild:
+ added python 3.2 abi support, solves bug #378923.
10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
crcmod-1.7.ebuild:
diff --git a/dev-python/crcmod/crcmod-1.7-r1.ebuild b/dev-python/crcmod/crcmod-1.7-r1.ebuild
new file mode 100644
index 000000000000..c9811f34dbc1
--- /dev/null
+++ b/dev-python/crcmod/crcmod-1.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/crcmod/crcmod-1.7-r1.ebuild,v 1.1 2011/10/10 18:32:11 sbriesen Exp $
+
+# For the 2.x versions of Python, these versions have been tested: 2.4 2.5 2.6 2.7
+# For the 3.x versions of Python, these versions have been tested: 3.1
+
+# Python 3.2 seems to work also; sbriesen 2011-10-10
+
+EAPI=3
+PYTHON_DEPEND="2:2.4:2.7 3:3.1:3.2"
+SUPPORT_PYTHON_ABIS="1"
+#RESTRICT_PYTHON_ABIS="3.2"
+
+inherit distutils
+
+DESCRIPTION="Python CRC Generator module"
+HOMEPAGE="http://crcmod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crcmod/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS="changelog test/examples.py"