summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-02 18:19:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-02 18:19:46 +0000
commit69ff0b368f961e54998fc76a6c41a259ef6c271c (patch)
tree2a59f537ba415467238f4733e1e0bd25c1ea7b33 /dev-python/cosmolopy
parentKeyword amd64-linux and x86-linux (diff)
downloadgentoo-2-69ff0b368f961e54998fc76a6c41a259ef6c271c.tar.gz
gentoo-2-69ff0b368f961e54998fc76a6c41a259ef6c271c.tar.bz2
gentoo-2-69ff0b368f961e54998fc76a6c41a259ef6c271c.zip
Keyword amd64-linux and x86-linux
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cosmolopy')
-rw-r--r--dev-python/cosmolopy/ChangeLog7
-rw-r--r--dev-python/cosmolopy/cosmolopy-0.1.102.ebuild42
-rw-r--r--dev-python/cosmolopy/cosmolopy-0.1.103.ebuild42
-rw-r--r--dev-python/cosmolopy/cosmolopy-0.1.104.ebuild4
4 files changed, 7 insertions, 88 deletions
diff --git a/dev-python/cosmolopy/ChangeLog b/dev-python/cosmolopy/ChangeLog
index 83629dd5f0df..438e7e3f1ec4 100644
--- a/dev-python/cosmolopy/ChangeLog
+++ b/dev-python/cosmolopy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cosmolopy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cosmolopy/ChangeLog,v 1.5 2012/02/20 14:18:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cosmolopy/ChangeLog,v 1.6 2012/08/02 18:19:46 bicatali Exp $
+
+ 02 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> -cosmolopy-0.1.102.ebuild,
+ -cosmolopy-0.1.103.ebuild, cosmolopy-0.1.104.ebuild:
+ Keyword amd64-linux and x86-linux
20 Feb 2012; Patrick Lauer <patrick@gentoo.org> cosmolopy-0.1.102.ebuild,
cosmolopy-0.1.103.ebuild, cosmolopy-0.1.104.ebuild:
@@ -45,4 +49,3 @@
+cosmolopy-0.1.001.ebuild, +files/cosmolopy-0.1.001-qa.patch,
+metadata.xml:
Initial import
-
diff --git a/dev-python/cosmolopy/cosmolopy-0.1.102.ebuild b/dev-python/cosmolopy/cosmolopy-0.1.102.ebuild
deleted file mode 100644
index 6a6dacd63cb5..000000000000
--- a/dev-python/cosmolopy/cosmolopy-0.1.102.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cosmolopy/cosmolopy-0.1.102.ebuild,v 1.4 2012/02/20 14:18:39 patrick Exp $
-
-EAPI=2
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-MY_PN=CosmoloPy
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Cosmology routines built on NumPy/SciPy"
-HOMEPAGE="http://roban.github.com/CosmoloPy/ http://pypi.python.org/pypi/CosmoloPy"
-SRC_URI="mirror://pypi/C/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="dev-python/nose
- dev-lang/swig
- doc? ( dev-python/epydoc )"
-RDEPEND="sci-libs/scipy"
-
-S=${WORKDIR}/${MY_P}
-
-src_install() {
- distutils_src_install
- if use doc; then
- einfo "Generation of documentation"
- epydoc -n "CosmoloPy - Cosmology routines built on NumPy/SciPy" \
- --exclude='cosmolopy.EH._power' --exclude='cosmolopy.EH.power' \
- --no-private --no-frames --html --docformat restructuredtext \
- cosmolopy/ -o docAPI/ || die
- dohtml -r docAPI/*
- fi
-}
diff --git a/dev-python/cosmolopy/cosmolopy-0.1.103.ebuild b/dev-python/cosmolopy/cosmolopy-0.1.103.ebuild
deleted file mode 100644
index 34640265b86d..000000000000
--- a/dev-python/cosmolopy/cosmolopy-0.1.103.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cosmolopy/cosmolopy-0.1.103.ebuild,v 1.2 2012/02/20 14:18:39 patrick Exp $
-
-EAPI=2
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-MY_PN=CosmoloPy
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Cosmology routines built on NumPy/SciPy"
-HOMEPAGE="http://roban.github.com/CosmoloPy/ http://pypi.python.org/pypi/CosmoloPy"
-SRC_URI="mirror://pypi/C/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="dev-python/nose
- dev-lang/swig
- doc? ( dev-python/epydoc )"
-RDEPEND="sci-libs/scipy"
-
-S=${WORKDIR}/${MY_P}
-
-src_install() {
- distutils_src_install
- if use doc; then
- einfo "Generation of documentation"
- epydoc -n "CosmoloPy - Cosmology routines built on NumPy/SciPy" \
- --exclude='cosmolopy.EH._power' --exclude='cosmolopy.EH.power' \
- --no-private --no-frames --html --docformat restructuredtext \
- cosmolopy/ -o docAPI/ || die
- dohtml -r docAPI/*
- fi
-}
diff --git a/dev-python/cosmolopy/cosmolopy-0.1.104.ebuild b/dev-python/cosmolopy/cosmolopy-0.1.104.ebuild
index d197be098122..250b745802a3 100644
--- a/dev-python/cosmolopy/cosmolopy-0.1.104.ebuild
+++ b/dev-python/cosmolopy/cosmolopy-0.1.104.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cosmolopy/cosmolopy-0.1.104.ebuild,v 1.1 2012/02/07 12:05:39 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cosmolopy/cosmolopy-0.1.104.ebuild,v 1.2 2012/08/02 18:19:46 bicatali Exp $
EAPI=4
@@ -19,7 +19,7 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
DEPEND="dev-python/nose