summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 04:20:01 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 04:20:01 +0000
commit47bf5497ea0b98bd8493f94a31197ec5841fc0e1 (patch)
treea47fbd9fc688d1601547baadfee86e496d811bde /dev-python/compizconfig-python
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-47bf5497ea0b98bd8493f94a31197ec5841fc0e1.tar.gz
gentoo-2-47bf5497ea0b98bd8493f94a31197ec5841fc0e1.tar.bz2
gentoo-2-47bf5497ea0b98bd8493f94a31197ec5841fc0e1.zip
Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release and to avoid future dep issues.
Did a revbump to avoid issues with installed packages. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/compizconfig-python')
-rw-r--r--dev-python/compizconfig-python/ChangeLog12
-rw-r--r--dev-python/compizconfig-python/compizconfig-python-0.8.4-r1.ebuild29
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/compizconfig-python/ChangeLog b/dev-python/compizconfig-python/ChangeLog
index a1f251948084..75c04c76c20f 100644
--- a/dev-python/compizconfig-python/ChangeLog
+++ b/dev-python/compizconfig-python/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/compizconfig-python
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/compizconfig-python/ChangeLog,v 1.16 2009/12/20 16:00:17 mrpouet Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/compizconfig-python/ChangeLog,v 1.17 2010/04/03 04:20:01 jmbsvicetto Exp $
+
+*compizconfig-python-0.8.4-r1 (03 Apr 2010)
+
+ 03 Apr 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +compizconfig-python-0.8.4-r1.ebuild:
+ Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6
+ release and to avoid future dep issues.
+ Did a revbump to avoid issues with installed packages.
20 Dec 2009; Romain Perier <mrpouet@gentoo.org>
-compizconfig-python-0.8.2.ebuild:
diff --git a/dev-python/compizconfig-python/compizconfig-python-0.8.4-r1.ebuild b/dev-python/compizconfig-python/compizconfig-python-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..c4a580f8d7c1
--- /dev/null
+++ b/dev-python/compizconfig-python/compizconfig-python-0.8.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/compizconfig-python/compizconfig-python-0.8.4-r1.ebuild,v 1.1 2010/04/03 04:20:01 jmbsvicetto Exp $
+
+inherit python
+
+DESCRIPTION="Compizconfig Python Bindings"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/python-2.4
+ >=dev-libs/glib-2.6
+ dev-python/pyrex
+ >=x11-libs/libcompizconfig-${PV}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_need_rebuild
+}