summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-21 12:55:08 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-21 12:55:08 +0000
commitfb95c780ed2b5dbff968ae95c116b9326226cc01 (patch)
tree591b72be0e96ce019d065fca7dea9c892836d351 /dev-python/charade
parentRemove old (diff)
downloadgentoo-2-fb95c780ed2b5dbff968ae95c116b9326226cc01.tar.gz
gentoo-2-fb95c780ed2b5dbff968ae95c116b9326226cc01.tar.bz2
gentoo-2-fb95c780ed2b5dbff968ae95c116b9326226cc01.zip
Use PYTHON_USEDEP to properly request implementation support in deps.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/charade')
-rw-r--r--dev-python/charade/ChangeLog6
-rw-r--r--dev-python/charade/charade-1.0.1.ebuild4
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/charade/ChangeLog b/dev-python/charade/ChangeLog
index 9bf0c717301d..5af0ee31bccb 100644
--- a/dev-python/charade/ChangeLog
+++ b/dev-python/charade/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for dev-python/charade
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/charade/ChangeLog,v 1.1 2012/12/17 19:48:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/charade/ChangeLog,v 1.2 2012/12/21 12:55:08 mgorny Exp $
+
+ 21 Dec 2012; Michał Górny <mgorny@gentoo.org> charade-1.0.1.ebuild:
+ Use PYTHON_USEDEP to properly request implementation support in deps.
*charade-1.0.1 (17 Dec 2012)
17 Dec 2012; Tim Harder <radhermit@gentoo.org> +charade-1.0.1.ebuild,
+metadata.xml:
Initial import, ebuild by me.
-
diff --git a/dev-python/charade/charade-1.0.1.ebuild b/dev-python/charade/charade-1.0.1.ebuild
index 07d1ffd862f0..8ce7ada75271 100644
--- a/dev-python/charade/charade-1.0.1.ebuild
+++ b/dev-python/charade/charade-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/charade/charade-1.0.1.ebuild,v 1.1 2012/12/17 19:48:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/charade/charade-1.0.1.ebuild,v 1.2 2012/12/21 12:55:08 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
@@ -16,4 +16,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"