summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-02-07 08:11:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-02-07 08:11:14 +0000
commit9d832c2c501d5f56c8c99af1c55063f4edc33eb8 (patch)
treed9c6450831f736bbfe6079eb3690808587176cae /dev-python/chameleon
parentFix aclocal failure on libmikmod-less systems (bundled .m4 bits). (diff)
downloadgentoo-2-9d832c2c501d5f56c8c99af1c55063f4edc33eb8.tar.gz
gentoo-2-9d832c2c501d5f56c8c99af1c55063f4edc33eb8.tar.bz2
gentoo-2-9d832c2c501d5f56c8c99af1c55063f4edc33eb8.zip
Bump for #402429
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/chameleon')
-rw-r--r--dev-python/chameleon/ChangeLog9
-rw-r--r--dev-python/chameleon/chameleon-2.7.0.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-python/chameleon/ChangeLog b/dev-python/chameleon/ChangeLog
index 90460e8adb9d..99ec81274d30 100644
--- a/dev-python/chameleon/ChangeLog
+++ b/dev-python/chameleon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/chameleon
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.7 2011/12/30 04:26:33 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.8 2012/02/07 08:11:14 patrick Exp $
+
+*chameleon-2.7.0 (07 Feb 2012)
+
+ 07 Feb 2012; Patrick Lauer <patrick@gentoo.org> +chameleon-2.7.0.ebuild:
+ Bump for #402429
*chameleon-2.6.1 (30 Dec 2011)
diff --git a/dev-python/chameleon/chameleon-2.7.0.ebuild b/dev-python/chameleon/chameleon-2.7.0.ebuild
new file mode 100644
index 000000000000..3f4aaff33fad
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/chameleon-2.7.0.ebuild,v 1.1 2012/02/07 08:11:14 patrick Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.7 3"
+RESTRICT_PYTHON_ABIS="2.[456]"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake html || die "make html failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests_and_incompatible_modules() {
+ rm -fr "${ED}$(python_get_sitedir)/chameleon/tests"
+
+ if [[ "$(python_get_version -l --major)" == "3" ]]; then
+ rm -f "${ED}$(python_get_sitedir)/chameleon/"{benchmark.py,py25.py}
+ fi
+ }
+ python_execute_function -q delete_tests_and_incompatible_modules
+
+ if use doc; then
+ pushd _build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static
+ popd > /dev/null
+ fi
+}