summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-06 07:44:44 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-06 07:44:44 +0000
commitf036004182ef771eef444f210421d078425a76f2 (patch)
tree560fc4ff04d81aa5f0bcc6ee570ee06f0faf9918 /dev-python/cgkit
parentFix GSettings schema not being installed. (diff)
downloadgentoo-2-f036004182ef771eef444f210421d078425a76f2.tar.gz
gentoo-2-f036004182ef771eef444f210421d078425a76f2.tar.bz2
gentoo-2-f036004182ef771eef444f210421d078425a76f2.zip
rem 1 unsupported test file, added patch to skip 1 invalid test, fixes Bug #420757
(Portage version: 2.1.11.30/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/cgkit')
-rw-r--r--dev-python/cgkit/ChangeLog8
-rw-r--r--dev-python/cgkit/cgkit-2.0.0_alpha9-r1.ebuild8
-rw-r--r--dev-python/cgkit/files/cgkit-2.0.0-test.patch11
3 files changed, 23 insertions, 4 deletions
diff --git a/dev-python/cgkit/ChangeLog b/dev-python/cgkit/ChangeLog
index 8fe76534a877..cbe6a6dc880a 100644
--- a/dev-python/cgkit/ChangeLog
+++ b/dev-python/cgkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cgkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.34 2012/06/14 18:49:09 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.35 2012/11/06 07:44:44 idella4 Exp $
+
+ 06 Nov 2012; Ian Delaney <idella4@gentoo.org> +files/cgkit-2.0.0-test.patch,
+ cgkit-2.0.0_alpha9-r1.ebuild:
+ rem 1 unsupported test file, added patch to skip 1 invalid test, fixes Bug
+ #420757
14 Jun 2012; Jeff Horelick <jdhore@gentoo.org> cgkit-2.0.0_alpha9-r1.ebuild:
marked x86 per bug 413815
@@ -153,4 +158,3 @@
30 Jul 2004; Chris Bainbridge <chrb@gentoo.org> +cgkit-1.1.0.ebuild:
New package
-
diff --git a/dev-python/cgkit/cgkit-2.0.0_alpha9-r1.ebuild b/dev-python/cgkit/cgkit-2.0.0_alpha9-r1.ebuild
index 806dcdd62987..fdd32fc25d03 100644
--- a/dev-python/cgkit/cgkit-2.0.0_alpha9-r1.ebuild
+++ b/dev-python/cgkit/cgkit-2.0.0_alpha9-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-2.0.0_alpha9-r1.ebuild,v 1.3 2012/06/14 18:49:09 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-2.0.0_alpha9-r1.ebuild,v 1.4 2012/11/06 07:44:44 idella4 Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit distutils
+inherit distutils eutils
MY_P="${P/_/}"
@@ -48,6 +48,10 @@ src_prepare() {
sed -e "s:INC_DIRS = \[\]:INC_DIRS = \['/usr/include'\]:" -i setup.py
sed -e "160s/as/as_/;168s/as/as_/" -i cgkit/flockofbirds.py
+
+ # Remove invalid test
+ rm -f unittests/test_pointcloud.py || die
+ epatch "${FILESDIR}"/${PN}-2.0.0-test.patch
}
src_compile() {
diff --git a/dev-python/cgkit/files/cgkit-2.0.0-test.patch b/dev-python/cgkit/files/cgkit-2.0.0-test.patch
new file mode 100644
index 000000000000..e5c198415da2
--- /dev/null
+++ b/dev-python/cgkit/files/cgkit-2.0.0-test.patch
@@ -0,0 +1,11 @@
+diff -ur cgkit-2.0.0alpha9.orig/unittests/test_sequence.py cgkit-2.0.0alpha9/unittests/test_sequence.py
+--- unittests/test_sequence.py 2009-08-15 19:37:35.000000000 +0800
++++ unittests/test_sequence.py 2012-11-07 06:58:07.024791790 +0800
+@@ -594,6 +594,7 @@
+ ("spam1_5.tif", "foo0006.tif")], list(ong))
+
+
++@unittest.skip("Seeks absent dep 3delight")
+ class TestSeqUtils(unittest.TestCase):
+ """Test the sequence utilities.
+ """